Bug 168042 - Mac OS Tiger breaks against samba 3.0.14a
Mac OS Tiger breaks against samba 3.0.14a
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
https://bugzilla.samba.org/show_bug.c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-11 12:02 EDT by Chris McDonough
Modified: 2014-08-31 19:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 22:29:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris McDonough 2005-09-11 12:02:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
Mac OS X Tiger's SMB client built into its Finder cannot successfully browse shares on a samba 3.0.14a server.  Attemping to browse the shares results in a Finder "hang".  Note that this problem does not happen with Mac OS X Panther or earlier.

The bug reports at https://bugzilla.samba.org/show_bug.cgi?id=2973 and http://bugs.gentoo.org/show_bug.cgi?id=101707 describe the problem in more detail.  The forum thread at http://forums.gentoo.org/viewtopic-t-366970-start-0-postdays-0-postorder-asc-highlight-.html describes several workarounds, too.

I haven't tried it yet, but Gerald Carter reports that the bug that is exposed by Tiger is fixed in samba 3.0.20, so I suspect the fix is just to repackage this version of samba. 

Version-Release number of selected component (if applicable):
samba-3.0.14a-2

How reproducible:
Always

Steps to Reproduce:
1. Open Mac OS X Tiger Finder.
2. Navigate to Network -> {workgroup} -> {systemname} and choose "Connect"

  

Actual Results:  The finder "beachballs" and hangs forever.  On the FC4 samba server, the /var/log/messages file includes:

Sep  5 04:53:07 plope smbd[29955]: [2005/09/05 04:53:07, 0] rpc_parse/parse_prs.
c:prs_mem_get(537)
Sep  5 04:53:07 plope smbd[29955]:   prs_mem_get: reading data of size 2 would o
verrun buffer.
Sep  5 04:53:07 plope smbd[29955]: [2005/09/05 04:53:07, 0] rpc_server/srv_pipe.
c:api_pipe_bind_req(919)
Sep  5 04:53:07 plope smbd[29955]:   api_pipe_bind_req: unable to unmarshall RPC
_HDR_RB struct.


Expected Results:  Should have seen the browseable shares in the Mac OS X Finder and no errors in the FC4 samba server's log file.

Additional info:
Comment 1 Chris McDonough 2005-09-11 18:12:41 EDT
I can confirm that compiling and using the SRPM from
http://us2.samba.org/samba/ftp/Binary_Packages/Fedora/SRPMS/samba-3.0.20-2.src.rpm
instead of the 3.0.14 RPM which is current for FC4 solves the issue. 
Comment 2 John Mahowald 2005-10-02 22:29:57 EDT
Rawhide has since been updated to 3.0.20.

Note You need to log in before you can comment on or make changes to this bug.