Bug 168051 - Nautilus lost file type associations, thumbnails & icons
Nautilus lost file type associations, thumbnails & icons
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-11 14:39 EDT by Edmond Hui
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-14 08:28:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edmond Hui 2005-09-11 14:39:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
Nautilus seems to be broken all of a sudden. The problem is solved once FC4 is reinstall, but happened again later.

Problems related are:
1) lost the ability to correctly determine the type of a file and associate it with its correct icon.
2) thumbnail function failed when new images are added to Desktop (either by drag n' drop, import from dig camera), even set from Preformances -> Preview.
3) Filesystem/CDROM-DVD drive/Floppy drive/Network icons from Computer lost its icons and display a "Couldn't display ..... The location is not a folder" error.

Version-Release number of selected component (if applicable):
nautilus-2.10.0-4

How reproducible:
Always

Steps to Reproduce:
unknown, the problem occurs all of a sudden.
  

Additional info:

This problem happened to more than one user: http://fedoraforum.org/forum/showthread.php?t=76248 (which has a screenshot of the problematic desktop)
Comment 1 Tim Niemueller 2005-10-09 14:36:08 EDT
Same problem here. An gthumb/eog cannot open image files anymore. Did anyone
gather some new information on this or even came up with a fix? I wouldn't care
about Nautilus but I'd really like to view my photos...
Comment 2 Alex Lancaster 2005-11-16 04:10:29 EST
I get the same problem, when clicking on the Computer icon on the GNOME desktop,
it shows Filesystem.desktop, Network.desktop with a generic "link" icon rather
than just "Filesystem", "Network" with the appropriate icons.   When clicking on
Filesystem, instead of displaying the icons it produces an error dialog:

 Couldn't display "computer:///Filesystem.desktop"
 The location is not a folder 

Even if I create a completely new user with a fresh desktop, the problem remains.
Comment 3 Alex Lancaster 2005-11-16 05:28:46 EST
I think I tracked this down to an errant package in review for Fedora Extras
that I built from an SRPM which overwrote some of /usr/share/mime.

To fix this, I removed the package in question, logged out of X (back to GDM)
and then logged into a virtual terminal as root and ran:

update-mime-database /usr/share/mime

then

update-desktop-database /usr/share/applications

for good measure.  Not sure which one fixed it, but I suspect the
update-mime-database (sorry I didn't do it as scientifically as I should have, I
was trying anything to get my desktop back!)

Upon logging back into an account the file types and icons appeared once more.
Comment 4 Alex Lancaster 2005-11-16 05:33:00 EST
OK, reinstalled the faulty package, and the problem manifested itself again.  A
simple run of:

sudo update-mime-database /usr/share/mime

fixed it without needing to logout or restart GNOME.
Comment 5 Edmond Hui 2005-11-16 15:04:12 EST
Confirmed the above comment fixed the problem.
Comment 6 Alexander Larsson 2005-12-14 08:28:05 EST
Closing this then. The package should be fixed to not overwrite the mime db.
Comment 7 Per Uddén 2006-11-13 09:26:25 EST
Is this also the case!
Nautilus render all mime types correctly for all ooo-documents after a update.
If i select some of the ooo-types it change to type application/x-java-archive
and also the default action. I can't change this behaivour anywhere.(In reply to
comment #6)
> Closing this then. The package should be fixed to not overwrite the mime db.
> 

Note You need to log in before you can comment on or make changes to this bug.