Bug 1680547 - snmptrapd crashes when forwarding SNMPv3 notifications
Summary: snmptrapd crashes when forwarding SNMPv3 notifications
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: net-snmp
Version: 7.6
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Josef Ridky
QA Contact: David Jež
URL:
Whiteboard:
Depends On:
Blocks: 1709111
TreeView+ depends on / blocked
 
Reported: 2019-02-25 10:04 UTC by Filip Krska
Modified: 2019-08-06 13:08 UTC (History)
5 users (show)

Fixed In Version: net-snmp-5.7.2-42.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1709111 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:08:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2239 None None None 2019-08-06 13:08:57 UTC

Description Filip Krska 2019-02-25 10:04:44 UTC
Description of problem:

snmptrapd crashes when forwarding SNMPv3 notifications

Version-Release number of selected component (if applicable):

net-snmp-5.7.2-37.el7

How reproducible:

Always

Steps to Reproduce:
1. cat /etc/snmp/snmptrapd.conf

createUser testuser SHA pwdpwdpwd AES pwdpwdpwd
authUser log,execute,net testuser noauth

disableAuthorization yes

forward default localhost:3000

2. systemctl restart snmptrapd.service

3. cat /tmp/snmptrapd2.conf 

createUser testuser SHA pwdpwdpwd AES pwdpwdpwd
authUser log,execute,net testuser noauth

snmpTrapdAddr 0.0.0.0:3000


4. snmptrapd -f -C -c /tmp/snmptrapd2.conf -Le &

5. snmptrap -Ci -v3 -u testuser -l noAuthNoPriv localhost 0 linkUp.0


Actual results:

# systemctl status snmptrapd.service
● snmptrapd.service - Simple Network Management Protocol (SNMP) Trap Daemon.
   Loaded: loaded (/usr/lib/systemd/system/snmptrapd.service; disabled; vendor preset: disabled)
   Active: failed (Result: signal) since Mon 2019-02-25 04:58:50 EST; 9s ago
  Process: 14163 ExecStart=/usr/sbin/snmptrapd $OPTIONS -f (code=killed, signal=SEGV)
 Main PID: 14163 (code=killed, signal=SEGV)


Expected results:

no segfault

Additional info:

Backtrace pattern same as in upstream report:

https://sourceforge.net/p/net-snmp/mailman/message/27984692/

Didn't reproduce with net-snmp-5.8-6.fc30.x86_64.rpm, net-snmp-5.8-7.el8.x86_64

Wasn't successful with identifying chunk which fixed the issue, corresponding Changelog entry so far, probably side effect of another fix/feature.

Comment 1 Filip Krska 2019-02-25 13:22:16 UTC
snmpinform -Ci -v3 -u testuser -l noAuthNoPriv localhost 0 linkUp.0

leads to crash as well...

Comment 18 errata-xmlrpc 2019-08-06 13:08:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2239


Note You need to log in before you can comment on or make changes to this bug.