Bug 168062 - wakeup (from suspend) works in 1398 but not in 1447 on T22 ThinkPad
wakeup (from suspend) works in 1398 but not in 1447 on T22 ThinkPad
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-11 22:25 EDT by Bruce vanNorman
Modified: 2015-01-04 17:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 17:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce vanNorman 2005-09-11 22:25:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
My T22 Thinkpads (two of them) will not wakeup after a suspend (either lid or sleep button) with kernel 2.6.12-1.1447_FC4, but work quite well with kernel 2.6.12-1.1398_FC4. acpid is 1.0.4-1.
----
I get the following messages with 1447 (I get many more with 1398, but they go by too fast to write down)
Back to C!
ACPI: PCI Interrupt 0000:00:02:0[A] -> Link [LNKA] -> GSI11 (level, low) -> IRQ 11
---
followed by five similar lines and then the laptop hangs with the crescent moon (suspend indicator) flashing at me. I must hold down the power button for 10 seconds to reboot.

Version-Release number of selected component (if applicable):
Fedora Core (2.6.12-1.1447_FC4)

How reproducible:
Always

Steps to Reproduce:
1. logon to any ser, run for a while
2. close lid or hit sleep button
3. open lid or hit sleep button
  

Actual Results:  The screen is black with the text messages described above
THe suspend indicator is flashing
all unsaved data is lost

Expected Results:  X-windows (for user) is up an running
The suspend indicator is off
system is running, data can be saved

Additional info:
Comment 1 Michael Selway 2005-09-13 15:36:47 EDT
A quick "me too": I upgraded my T21 (pretty similar to a T22) from FC3 to FC4 a 
couple of days ago.  Won't recover from suspend using kernel 2.6.12-1.1447_FC4. 
Resumes back to text screen, moon light flashes, but otherwise dead. Suspend 
works find if I regress to 2.6.12-1.1398_FC4. I'm surprised there isn't more 
noise about this.  Maybe it's just you and me!
Comment 2 Warren Togami 2005-09-13 17:53:02 EDT
http://people.redhat.com/davej/kernels/Fedora/
Please test the newer test kernel from here and report back.
Comment 3 Michael Selway 2005-09-14 04:23:05 EDT
Same incorrect behaviour with kernel
http://people.redhat.com/davej/kernels/Fedora/FC4/RPMS.kernel/kernel-2.6.12-1.1454_FC4.i686.rpm

Suspends fine, begins to resume OK, then blinks moon LED while displaying the
normal text suspend/resume page.  machine is frozen and needs a full reset to
recover.
Comment 4 Bruce vanNorman 2005-09-14 12:09:45 EDT
Also grandson reported that his T22 would not power down. Always required full
reset. Confirmed (it was defaulting to 1447) and reproduced same on my T22. I
don't remember having the problem when I first installed 1447. Changed
"grub.conf" to default to 1398 and shutdown now powers both machines down.
---
Factoid - when booting my T22 with 1447 & "acpi=off", both suspend and shutdown
functions work (2 tests). I don't like APM (as opposed to ACPI) as a "solution".
We (grandson & self) have 2nd (auxilliary) batteries and APM does not
distinguish. We use "gkrellm" to monitor them.
---
Factoid - ACPI seems to have better power management. Extended use of T22's
under APM management often results in over heating and machine freeze up.
Comment 5 Bruce vanNorman 2005-09-16 22:37:27 EDT
I tried "DaveJ" kernel 1455.
- wakeup from suspend hangs after PCI messages with blinking "moon". Hardware
reset required.
- Shutdown turns off the machine, unlike 1447, Yea!
Comment 6 Bruce vanNorman 2005-09-16 22:49:48 EDT
OOps, spoke too soon on 1455
- hardware turns off from GUI shutdown.
- hardware does not turn off from ACPI script (power button) as shipped as an
example with FC4. Last line is "Shutdown: hda". Hardware reset required.
Comment 7 Bruce vanNorman 2005-09-23 15:55:41 EDT
Just downloaded and tested kernel 1.1456 ... FC4 .. i686. on the T22 Thinkpad.
- improvement, the power button now turns the machine off correctly.
- same old, neither the sleep button nor lid button restores Fedora from
suspend. The hang symptoms are the same as with 1447 & 1455. A machine reset is
required to recover. 1.1398 remains the best choice.
Comment 8 Rudolf Ulc 2005-09-24 05:05:38 EDT
Thinkpad T20 would not power down and ibm_acpi module not loaded. 
modprobe ibm_acpi
FATAL: Error inserting ibm_acpi
(/lib/modules/2.6.12-1.1456_FC4/kernel/drivers/acpi/ibm_acpi.ko): No such device
Comment 9 Mitch Smith 2005-09-24 14:11:25 EDT
Second the motion that FC4 suspend on IBM T-21 continues to be broken with
kernel 1456. Laptop suspends but will not wakeup. If I revert to kernel 1398 the
machine operates perfectly. 
Comment 10 Bruce vanNorman 2005-09-24 17:38:25 EDT
I sometimes wonder about my ACPI scripts. I haven't found anything like Fedora
laptop standards. Are mine correct? What I am using is:
#!/bin/sh
# /etc/acpi/actions/lid.sh
hwclock --systohc
echo mem > /sys/power/state
hwclock --hctosys
--
does this match the standards and expectations of Fedora? Just because it works
under 1398 doesn't mean I got it right. Is there a laptop community that
monitors Fedora laptop standards?
Comment 11 Kevin Fenzi 2005-09-26 15:06:22 EDT
Just a shot in the dark, but could you guys seeing this problem try removing the
usb modules before suspending? 

rmmod uhci-hcd
rmmod ehci-hcd

On my t42p I remove them before suspend, and all the above kernels work for me. 
I note that they are (at least here) on irq 11, which the orig reporter had a
kernel message about. 
Comment 12 Michael Selway 2005-09-27 06:11:10 EDT
First thing I tried when I got this problem was removing all the modules which
were removable, immediately after a re-boot, and then running an acpi suspend.
The problem still occurred - the machine begins to resume but freezes while
displaying the normal ACPI text resume screen, with blinking moon LED.  Needs
hard reset to recover.  I can't be *sure* the USB modules were removed but I
believe they will have been. Next time I reboot I will try and remember to check
this explicitly.

So for now I think the USB modules are not suspects.
Comment 13 Dave Jones 2005-09-30 02:43:56 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 14 Michael Selway 2005-09-30 18:41:15 EDT
kernel-2.6.13-1.1526_FC4 fixes the suspend fault on my T21.  Excellent!  From
where I'm sitting, this issue is now closed.  Bruce?
Comment 15 Bruce vanNorman 2005-10-03 03:15:05 EDT
I've tested kernel-2.6.13-1.1526 on two T22's a number of times over this day
and it appears to work as it did with 2.6.12-1.1398. Suspend / wakeup with
either lid/button or sleep/button works correctly. power/button turns off both
machines. Hardware resets are no longer required. I believe that this build
corrects the problem. We will keep a watch on it for the rest of the week.
Barring unforseen events, I concur - the bug should be closed.
---
As was commented in the source code of the "Collosal Cave" (the original
adventure game, written in FORTRAN) - "good work men, you deserve a cookie" :-)
Comment 16 Dave Jones 2005-10-03 17:53:10 EDT
mmm cookie.

Note You need to log in before you can comment on or make changes to this bug.