Bug 1680664 - podman pull shows the blob progress twice
Summary: podman pull shows the blob progress twice
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: podman
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Valentin Rothberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-25 13:40 UTC by Jan Pazdziora
Modified: 2019-03-15 03:35 UTC (History)
6 users (show)

Fixed In Version: podman-1.1.2-1.git0ad9b6b.fc29 podman-1.1.2-1.git0ad9b6b.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-10 18:23:30 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2019-02-25 13:40:02 UTC
Description of problem:

When pulling image, podman shows the progress of the download, but it now shows the progress line twice.

Version-Release number of selected component (if applicable):

podman-1.0.1-28.dev.git0a521e1.fc30.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. sudo podman pull registry.fedoraproject.org/fedora:29

Actual results:

Trying to pull docker://registry.fedoraproject.org/fedora:29...Getting image source signatures
Copying blob 472dbbf50fa6: 88.06 MiB / 88.69 MiB [=============================]
Copying blob 472dbbf50fa6: 88.69 MiB / 88.69 MiB [==========================] 7s
Copying config 69c5db8b64a7: 1.27 KiB / 1.27 KiB [==========================] 0s
Writing manifest to image destination
Storing signatures
69c5db8b64a76b5f0b3ac812f317f828d3d4d8e7b399ea196de6de659c225b96

Expected results:

Trying to pull registry.fedoraproject.org/fedora:29...Getting image source signatures
Copying blob 472dbbf50fa6: 88.69 MiB / 88.69 MiB [==========================] 4s
Copying config 69c5db8b64a7: 1.27 KiB / 1.27 KiB [==========================] 0s
Writing manifest to image destination
Storing signatures
69c5db8b64a76b5f0b3ac812f317f828d3d4d8e7b399ea196de6de659c225b96

Additional info:

This is a regression against podman-1.0.0-1.git82e8011.fc29.x86_64.

Comment 1 Valentin Rothberg 2019-02-25 16:21:15 UTC
Hi Jan,

thanks for reporting the bug. It's already fixed upstream and will be available with the upcoming release of Podman v1.1 and eventually in the packages for Fedora.

Kind regards,
 Valentin

Comment 2 Daniel Walsh 2019-02-25 21:59:34 UTC
Jan, could you try with the latest podman in Rawhide, and make sure it is fixed.


I see
podman-1.0.1-31.dev.git228d1cb.fc30

Comment 3 Jan Pazdziora 2019-02-26 08:33:59 UTC
With

# rpm -q podman
podman-1.0.1-31.dev.git228d1cb.fc30.x86_64

the behaviour is still the same:

# sudo podman pull registry.fedoraproject.org/fedora:29
Trying to pull docker://registry.fedoraproject.org/fedora:29...Getting image source signatures
Copying blob 0b134f8f4722: 88.70 MiB / 88.70 MiB [=============================]
Copying blob 0b134f8f4722: 88.70 MiB / 88.70 MiB [========================] 1m8s
Copying config 81174df11aeb: 1.27 KiB / 1.27 KiB [==========================] 0s
Writing manifest to image destination
Storing signatures
81174df11aeb5baf4ecf69d936b72c329d2ec3d3becec52f07caeeb414cab3f2

Comment 4 Valentin Rothberg 2019-02-26 08:36:26 UTC
The bug cannot be replicated on all machines, unfortunately. It worked perfectly on my machine but appeared on others.

It will be fixed with the upcoming Podman v1.1 though.

Kind regards,
 Valentin

Comment 5 Daniel Walsh 2019-02-26 14:19:59 UTC
Valentin he is testing the v1.1 code base.

Rawhide gets the latest code out of master branch automatically.

Comment 6 Valentin Rothberg 2019-02-26 14:27:36 UTC
(In reply to Daniel Walsh from comment #5)
> Valentin he is testing the v1.1 code base.
> 
> Rawhide gets the latest code out of master branch automatically.

Thanks for the clarification, Dan.

It looks like the latest package in Rawhide does not yet ship the code as the comment#3 does not show the format of the new progress bars. The format has slightly changed, see below:

[valentin@nebuchadnezzar libpod]$ ./bin/podman pull registry.fedoraproject.org/fedora:29
Trying to pull docker://registry.fedoraproject.org/fedora:29...Getting image source signatures
Copying blob 0b134f8f4722 [======================================] 88.7MiB / 88.7MiB
Copying config 81174df11a [======================================] 1.3KiB / 1.3KiB
Writing manifest to image destination
Storing signatures
81174df11aeb5baf4ecf69d936b72c329d2ec3d3becec52f07caeeb414cab3f2

Comment 7 Daniel Walsh 2019-02-26 14:33:21 UTC
Ok Jan, tomorrows Rawhide hopefully will have the fix.

Comment 8 Fedora Update System 2019-02-27 13:30:15 UTC
podman-1.1.0-1.git006206a.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2334f59273

Comment 9 Fedora Update System 2019-02-27 13:30:28 UTC
podman-1.1.0-1.git006206a.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ead0cd452a

Comment 10 Fedora Update System 2019-02-28 18:55:36 UTC
podman-1.1.0-1.git006206a.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2334f59273

Comment 11 Fedora Update System 2019-02-28 21:26:26 UTC
podman-1.1.0-1.git006206a.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ead0cd452a

Comment 12 Fedora Update System 2019-03-05 19:11:10 UTC
podman-1.1.2-1.git0ad9b6b.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d244a0fe3e

Comment 13 Fedora Update System 2019-03-05 19:11:23 UTC
podman-1.1.2-1.git0ad9b6b.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5730099f0b

Comment 14 Fedora Update System 2019-03-06 15:12:59 UTC
podman-1.1.2-1.git0ad9b6b.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d244a0fe3e

Comment 15 Fedora Update System 2019-03-06 15:57:13 UTC
podman-1.1.2-1.git0ad9b6b.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-5730099f0b

Comment 16 Fedora Update System 2019-03-10 18:23:30 UTC
podman-1.1.2-1.git0ad9b6b.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2019-03-15 03:35:16 UTC
podman-1.1.2-1.git0ad9b6b.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.