Bug 168068 - xsane coredumps inside snapscan backend with current devel packages
xsane coredumps inside snapscan backend with current devel packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-12 00:36 EDT by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 02:22:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2005-09-12 00:36:00 EDT
I upgraded something like 400 packages on my machine today to current devel
packages.  After this, xsane coredumps upon startup when trying to access my
Epson Perfection 2480 scanner, which uses the snapscan driver.  I installed
sane-backends-debuginfo and got this stack trace:

#0  0xb7687572 in sanei_constrain_value (opt=0x974cde0, value=0x0, 
    info=0xbf9bacc4) at sanei_constrain_value.c:123
#1  0xb767f1eb in sane_snapscan_control_option (h=0x974c900, n=24, 
    a=SANE_ACTION_SET_VALUE, v=0x0, i=0xbf9bacc4) at snapscan-options.c:1014
#2  0xb7f8ab60 in sane_dll_control_option (handle=0x9748a40, option=24, 
    action=SANE_ACTION_SET_VALUE, value=0x0, info=0xbf9bacc4) at dll.c:1134
#3  0xb7f8c089 in sane_control_option (h=0x9748a40, opt=24, 
    act=SANE_ACTION_SET_VALUE, val=0x0, info=0xbf9bacc4) at dll-s.c:34
#4  0x0804e7cb in ?? ()
#5  0x0807a877 in ?? ()
#6  0x0807b114 in ?? ()
#7  0x0807b2a5 in ?? ()
#8  0x080b05fe in ?? ()
#9  0x080b33f8 in ?? ()
#10 0x080b4546 in ?? ()
#11 0xb7a584ff in __libc_start_main () from /lib/libc.so.6
#12 0x0804e3f1 in ?? ()

I tried backing out to old versions of sane-backends, gtk2 and glibc, the three
packages that seemed from the stack trace to be relevant, but backing out didn't
make the problem go away, even though I wasn't having the problem before I
upgraded today.  I found that I was able to make xsane start properly by
unplugging the scanner's usb cable, unplugging its power cable, plugging the USB
cable back in, waiting 10 seconds, plugging the power cable back in, and then
running xsane again.  However, I subsequently exit and restart xsane without
repeating that whole process, I get the coredump again.

As I say, I don't think this was happening before, but I can't prove it since I
wasn't able to find a combination of old packages which made the problem go away.

I have current devel versions of all the packages installed on my system as of
about a half hour ago on ftp.tu-chemnitz.de.
Comment 1 Nils Philippsen 2005-10-11 04:09:59 EDT
Can you please try whether this problem persists with current Rawhide packages
(namely xsane-0.97) and report back? Thanks.
Comment 2 Jonathan Kamens 2005-10-14 05:29:30 EDT
Yes, it does.
Comment 3 Nils Philippsen 2006-06-07 09:12:22 EDT
Can you please check whether this problem persists with current xsane-0.99?
Sorry I can't help more, but I don't have access to your hardware.
Comment 4 Jonathan Kamens 2006-06-14 01:40:51 EDT
I can no longer duplicate the problem with what's currently in Raw hide.

Note You need to log in before you can comment on or make changes to this bug.