Bug 168088 - Maximum number of filedescriptors set to 1024 (SQUID_MAXFD)
Maximum number of filedescriptors set to 1024 (SQUID_MAXFD)
Status: CLOSED DUPLICATE of bug 72896
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Depends On:
  Show dependency treegraph
Reported: 2005-09-12 07:01 EDT by Paul P Komkoff Jr
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-19 04:13:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul P Komkoff Jr 2005-09-12 07:01:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
When squid ./configure script runs, it trying to detect maximum number of filedescriptors it can open. By default, ulimit is set to 1024.

1024 may be suitable for single-user deployment, but absolutely unsuitable for 1200 hosts behind proxy. For this situations, more suitable value is, perhaps, 16384.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
rpmbuild --rebuild and see messages it emits
Ctrl-C in progress and see SQUID_MAXFD set to 1024 in autoconf.h

Additional info:
Comment 1 Paul P Komkoff Jr 2005-09-12 07:05:22 EDT
Something like this will be enough I think

diff -urN squid-2.5.STABLE10.orig/configure squid-2.5.STABLE10/configure
--- squid-2.5.STABLE10.orig/configure   2005-05-17 02:41:14.000000000 +0400
+++ squid-2.5.STABLE10/configure        2005-09-09 23:17:41.000000000 +0400
@@ -8308,6 +8308,8 @@
 rm -fr conftest*

 echo "$ac_t""$SQUID_MAXFD" 1>&6
 cat >> confdefs.h <<EOF
diff -urN squid-2.5.STABLE10.orig/configure.in squid-2.5.STABLE10/configure.in
--- squid-2.5.STABLE10.orig/configure.in        2005-05-17 02:41:14.000000000 +0400
+++ squid-2.5.STABLE10/configure.in     2005-09-09 23:18:13.000000000 +0400
@@ -2108,6 +2108,7 @@
 SQUID_MAXFD=`cat conftestval`,
 if test "$SQUID_MAXFD" -lt 512 ; then
Comment 2 Martin Stransky 2005-09-19 04:13:39 EDT
Please, route this issue to upstream, http://www.squid-cache.org/ and file the
request here. I don't want to change this default value for Fedora only. And If
you have to manage a large site, you surely don't use the default values but you
do some tuning.
Comment 3 Paul P Komkoff Jr 2005-09-19 07:53:56 EDT
Of course I'm doing some tuning! Rebuilding squid with maxfd patched, and
putting it in exclude= line of my yum.conf to avoid "official" broken package
from slipping into server.

Seriously, I wrote mail to "upstream". But what we have in fedora is just build
system deficiency on the one side (one cannot set ulimit -HSn 16384 prior to
build), and you, claiming this bug as a feature, on the other.
Comment 4 Martin Stransky 2005-12-01 09:52:56 EST

*** This bug has been marked as a duplicate of 72896 ***

Note You need to log in before you can comment on or make changes to this bug.