Bug 168103 - mutt crashes after authentication with imaps server
mutt crashes after authentication with imaps server
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-12 10:21 EDT by Boris Glawe
Modified: 2014-03-16 22:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 10:08:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of mutt until the freeze point (44.54 KB, text/plain)
2005-09-12 17:52 EDT, Boris Glawe
no flags Details

  None (edit)
Description Boris Glawe 2005-09-12 10:21:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
mutt -f imaps://user@mailserver results in a prompt asking whether I accept the certificate, and prompting for username and password.

Entering a wrong password results in a SASL Authentication failure as expected

Entering the correct passwords freezes mutt. It doesn't respond to anything - not even to Ctrl-C or Ctrl-Z.

The connection can successfully established from our solaris client. It's not the mailservers fault, since it perfectly works with other mailclients.

I haven't configured any firewall.

Version-Release number of selected component (if applicable):
mutt-1.4.1-10 

How reproducible:
Always

Steps to Reproduce:
1.connect to an imaps server (with ssl)
2.enter your correct password
3.wait for years - nothing will happen
  

Actual Results:  mutt freezes

Expected Results:  mutt should load the headers

Additional info:
Comment 1 Bill Nottingham 2005-09-12 13:21:47 EDT
Can you get a strace?
Comment 2 Boris Glawe 2005-09-12 17:52:39 EDT
Created attachment 118743 [details]
strace of mutt until the freeze point
Comment 3 Bill Nottingham 2005-09-12 17:57:57 EDT
Hm, so it's hanging reading from the server socket. What sort of imap server?
Comment 4 Boris Glawe 2005-09-13 10:07:48 EDT
By applying the settings from this homepage, it worked fine, I don't know, what
caused the behaviour I experienced before, but it's working now! Thanks!

https://mailbox.informatik.uni-bonn.de/mutt.html

Note You need to log in before you can comment on or make changes to this bug.