Bug 168105 - Bad: Authentication against Active Directory doesnt work
Bad: Authentication against Active Directory doesnt work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.0
powerpc Linux
medium Severity low
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-12 10:28 EDT by Michael Lang
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: samba-3.0.25b-0.4E.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 18:58:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lang 2005-09-12 10:28:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.1

Description of problem:
Bad:
Authentication against Active Directory doesnt work as expected.
using wbinfo -u lists all Users from the Domain where getent passwd 
just returns one Accout (usualy Administrator) and nothing else except :0::::
The winbindd Logs reports problems with the uid/gid numbers 
 "idmap Fatal Error: UID range full!! (max: 20000)"

I did first blame M$ as it seems to be the License of the SBS Server
i was trying to authenticate against, since authentication against AD on
x86 on another Site/AD worked fine with samba*-3.0.10-1.4E.

My colleague setup authentication using SUSE EL9 which work fine without
any problems. If then tryed to recompile samba-*3.0.14a-2 on the PPC System
and after upgrading it worked fine.



Version-Release number of selected component (if applicable):
samba*-3.0.10-1.4E

How reproducible:
Always

Steps to Reproduce:
1.Install EL4 on PPC samba Version samba*-3.0.10-1.4E.
2.Setup AD Authentication for Samba
3.try wbinfo -u and getent passwd
  

Actual Results:  \uffffPPERICOM+administrator::0:100000:::
::0:100001:::
::0:100002:::
::0:100003:::
...

Expected Results:  PERICOM+administrator:*:10000:10000:Administrator:/home/PERICOM/administrator:/bin/false
PERICOM+gast:*:10001:10001:Gast:/home/PERICOM/gast:/bin/false
PERICOM+iusr_batman:*:10002:10000:IUSR_BATMAN:/home/PERICOM/iusr_batman:/bin/false
PERICOM+iwam_batman:*:10003:10000:IWAM_BATMAN:/home/PERICOM/iwam_batman:/bin/false
PERICOM+support_388945a0:*:10004:10000:SUPPORT_388945a0:/home/PERICOM/support_388945a0:/bin/false
...

Additional info:

fixed by upgrading samba to version samba-3.0.14a-2
Comment 1 Simo Sorce 2007-11-21 18:58:55 EST
I am closing this as we released 3.0.25 and that should cover this issue as well.
Reopen if not.

Note You need to log in before you can comment on or make changes to this bug.