Bug 168155 - anaconda does not look for help files in /tmp/updates
Summary: anaconda does not look for help files in /tmp/updates
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-12 22:17 UTC by Jeffrey Hutzelman
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 18:08:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeffrey Hutzelman 2005-09-12 22:17:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When the install media contains an updates.img, it is mounted temporarily and its contents are copied into /tmp/updates, which appears on the search paths for python modules, pixmaps, and help files.  We use this mechansim (and not the RHupdates directory, which works only for NFS installs) to fix bugs and add functionality to the installer, such as an additional UI screen which gathers site-specific configuration.

Unfortunately, while /mnt/source/RHupdates is on the search path for help files, /tmp/updates is not.  This means we are unable to override the help files that ship with anaconda (for example, to provide partitioning guidelines) or to add help files for our site-specific UI page.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make a copy of /usr/share/anaconda/help/C/s1-help-screens-partition.html
2. Make some obvious modification
3. Build an ext2 filesystem image containing help/C/s1-help-screens-partition.html
4. Add the image to the installer media as Fedora/base/updates.img
5. Look at the help screen in the installer.

Actual Results:  The help screen is the same as that in the stock installer.

Expected Results:  The help screen should have been the locally-modified version in updates.img

Additional info:

This has actually been a problem for us at least since RH9, but we've always worked around it by creating symlinks in a kickstart %pre script:

ln -s /tmp/updates/help /help
ln -s /tmp/updates/help /text-help

We'd prefer not to have to do this in the future.


Fixing this should require changes to gui.py at line 1454 (at the top of InstallControlState.__init__) and to text.py at line 177 (in InstallInterface.helpWindow).  (line numbers are in anaconda-10.1.0.2)

In both cases, an entry for /tmp/updates should be added after the existing entry for /mnt/source/RHupdates.

Comment 1 Rahul Sundaram 2005-09-12 22:43:04 UTC

Moving to devel since this isnt FC3 specific

Comment 2 Jeremy Katz 2005-09-19 18:08:33 UTC
Fixed in CVS, although the help may be going away in FC5


Note You need to log in before you can comment on or make changes to this bug.