This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 168159 - Unable to boot kernel-2.6.13-1.1549_FC5: hda: lost interrupt issue
Unable to boot kernel-2.6.13-1.1549_FC5: hda: lost interrupt issue
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-12 20:46 EDT by Rodd Clarkson
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 22:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2005-09-12 20:46:15 EDT
Description of problem:

Each time I try to boot the kernel-2.6.13-1.1549_FC5 it fails, stopping at some
point in the process.  By editing grub as follows:

        root (hd0,2)
        kernel /vmlinuz-2.6.13-1.1549_FC5 ro root=LABEL=/
        initrd /initrd-2.6.13-1.1549_FC5.img

I get the following output (I've had to write it down by hand and I haven't got
all the stuff at the top, but hopefully I've got the relevant stuff)

Loading sd_mod.ko module
Loading libata.ko module
Loading ata_piix.ko module
ACPI: PCI Interrupt 0000:00:1f.2[B] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
ata: 0x1f0 IDE port busy
ata: 0x170 IDE port busy
ata_piix: probe of 0000:00:1f.2 failed with error -16
Loading ahci.ko module
ACPI: PCI Interrupt 0000:00:1f.2[B] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
ACPI: PCI Interrupt for device 0000:00:1f.2 disabled
ahci: probe of 0000:00:1f.2 failed with error -12
Loading jbd.ko module
Loading ext3.ko module
Going to resume from LABEL=SWAP-sda8
input: PS/2 Mouse on isa0060/serio1
input: AlpsPS/2 ALPS GlidePoint on isa0060/serio1
hda: lost interrupt
hda: lost interrupt
hda: lost interrupt
hda: lost interrupt
hda: lost interrupt
hda: lost interrupt
hda: lost interrupt
hda: lost interrupt
hda: lost interrupt
hda: lost interrupt
[repeats hda: lost interrupt]

The hda: lost interrupt line appears about every five or ten seconds.


Version-Release number of selected component (if applicable):

kernel-2.6.13-1.1549_FC5


How reproducible:

Everytime


Additional Information:

I can't help but wonder if this hasn't got something to do with bug #166053. 
All the right ingredients are there (libata.ko, ata_piix.ko, etc).  Also, others
are having no troubles booting this kernel on a range of platforms, so I can't
help but feel it's related to something specific to do with my hardware.
Comment 1 Rodd Clarkson 2005-09-13 19:41:01 EDT
Unable to boot kernel-2.6.13-1.1552_FC5 also.

Same symptoms. :-[
Comment 2 Jeremy Katz 2005-09-13 19:51:58 EDT
What device is hda?  Can you try booting with ide=nodma and also hda=off?
Comment 3 Rodd Clarkson 2005-09-13 20:22:01 EDT
The hda device is a hard disk drive.  Specifically a Fujitsu MHV2100AH.

lshal tells me:

udi = '/org/freedesktop/Hal/devices/storage_serial_NT23T5626300'
  storage.policy.should_mount = false  (bool)
  block.storage_device =
'/org/freedesktop/Hal/devices/storage_serial_NT23T5626300'  (string)
  info.udi = '/org/freedesktop/Hal/devices/storage_serial_NT23T5626300'  (string)
  storage.firmware_version = '00000096'  (string)
  storage.serial = 'NT23T5626300'  (string)
  storage.requires_eject = false  (bool)
  storage.hotpluggable = false  (bool)
  info.capabilities = {'storage', 'block'} (string list)
  info.category = 'storage'  (string)
  info.product = 'FUJITSU MHV2100AH'  (string)
  storage.removable = false  (bool)
  storage.physical_device = '/org/freedesktop/Hal/devices/computer_ide_0_0' 
(string)
  storage.drive_type = 'disk'  (string)
  storage.vendor = ''  (string)
  storage.model = 'FUJITSU MHV2100AH'  (string)
  storage.automount_enabled_hint = true  (bool)
  storage.media_check_enabled = false  (bool)
  storage.no_partitions_hint = false  (bool)
  storage.bus = 'ide'  (string)
  block.is_volume = false  (bool)
  block.minor = 0  (0x0)  (int)
  block.major = 3  (0x3)  (int)
  block.device = '/dev/hda'  (string)
  linux.hotplug_type = 3  (0x3)  (int)
  info.parent = '/org/freedesktop/Hal/devices/computer_ide_0_0'  (string)
  linux.sysfs_path_device = '/sys/block/hda'  (string)
  linux.sysfs_path = '/sys/block/hda'  (string)
Comment 4 Rodd Clarkson 2005-09-13 20:23:00 EDT
Also, neither ide=nodma or hda=off had any effect on th problem.

Should I try both together?
Comment 5 Rodd Clarkson 2005-09-15 06:35:03 EDT
Unable to boot kernel-2.6.13-1.1553_FC5 also.

Same symptoms. :-[

Unable to install kernel-2.6.13-1.1555_FC5, but I've asked on devel-list about this.
Comment 6 Rodd Clarkson 2005-09-15 07:05:39 EDT
I've installed kernel-2.6.13-1.1555_FC5 and this has the same problem.
Comment 7 Rodd Clarkson 2005-09-18 00:26:43 EDT
Okay, let me offer and apology, and then make some observations.

A little surprised that this wasn't affecting others I decided I would take me
FC4 install on the same laptop and upgrade it to rawhide.  The FC4 install
hadn't been used, with the exception of updating shortly after FC4 was released.
 After updating to rawhide I can now boot from the 1555 kernel (which came with
the update, other kernels can't be accesses for testing, but I'd be confident
they work too.)

So sorry about reporting this bug in the first place.

This said, I've been updating FC4 to rawhide on a regular (almost daily) basis
since about three weeks after FC5 was released.  Somewhere along the line
something went wrong with booting kernels, but I'm (and obviously others here)
confused as to why.

Would you like to keep this bug open to try and figure out what the difference
is, or whould we just close it.  The lost interrupt problem happens pretty early
in boot, so I'm surprised that it's an issue, (especially since I can now boot
one of the kernels in question) and there can't be too much happening that could
cause this since it happens so early.

Thoughts?
Comment 8 Dave Jones 2005-09-21 22:51:12 EDT
*shrug*, if it reoccurs, please reopen.
Until then, I don't have any suggestions.
Comment 9 Jesse Barnes 2005-10-15 12:11:20 EDT
I've been seeing this behavior for awhile now too (sorry I didn't file a report
I only just got a bz account).

I found that if I use the non-libata driver (just ide-disk) things work fine. 
So now my machine is running non-DMA on /dev/hda instead of libata goodness on
/dev/sda, but at least it doesn't hang at boot.  I don't remember when this
problem started occurring, but given that Jeff says ATAPI+libsata isn't ready I
guess we don't have much of a choice right now?

Jesse

Note You need to log in before you can comment on or make changes to this bug.