Bug 168191 - devel lacks gnome-keyring-devel dependency
devel lacks gnome-keyring-devel dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnomeui (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-13 08:34 EDT by Dmitry Butskoy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 10:16:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Butskoy 2005-09-13 08:34:32 EDT
Description of problem:

There is no "Requires: gnome-keyring-devel" for libgnomeui-devel.
Due to this, it is impossible to build some packages under "Fedora Extra devel"
build system.


Version-Release number of selected component (if applicable):
libgnomeui-devel-2.12.0-1


How reproducible:
Try to remove gnome-keyring-devel:

rpm -e gnome-keyring-devel

leaving libgnomeui-devel . Currently rpm will allow it. Then run:

pkg-config --exists "libgnomeui-2.0"
Comment 1 Ray Strode [halfline] 2005-09-13 10:16:23 EDT
Hi Dmitry,

Seems to have been fixed yesterday:

* Mon Sep 12 2005 Jeremy Katz <katzj@redhat.com> - 2.12.0-2
- devel subpackage requires gnome-keyring-devel (noticed by Marc Maurer)


Note You need to log in before you can comment on or make changes to this bug.