This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 168212 - mod_auth_kerb SRPM doesn't build as non-root
mod_auth_kerb SRPM doesn't build as non-root
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_auth_kerb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-13 11:39 EDT by Roozbeh Pournader
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 5.0-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 08:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fix the problem (529 bytes, patch)
2005-09-13 11:39 EDT, Roozbeh Pournader
no flags Details | Diff

  None (edit)
Description Roozbeh Pournader 2005-09-13 11:39:48 EDT
Description of problem:
mod_auth_kerb's SRPM does not build as a non-root user. It is because when it
searches for apache's apxs, it does not include /usr/sbin in its path. The
problem is there for both Rawhide and FC4. Attached a patch.

Version-Release number of selected component (if applicable):
mod_auth_kerb-5.0-6

How reproducible:
Always

Steps to Reproduce:
1. Login as a non-root user.
2. rpm -Uvh mod_auth_kerb-5.0-6.src.rpm
3. cd rpmbuild/SPECS (or wherever the spec files are)
4. rpmbuild -ba mod_auth_kerb.spec
  
Actual results:
It fails with an error message that includes:

   checking for apxs... no
   configure: error: failed to find apache apxs executable

Expected results:
It should not fail.
Comment 1 Roozbeh Pournader 2005-09-13 11:39:48 EDT
Created attachment 118755 [details]
Patch to fix the problem
Comment 2 Joe Orton 2005-09-21 08:56:26 EDT
Thanks a lot, building for Raw Hide now.

Note You need to log in before you can comment on or make changes to this bug.