Bug 168231 - Unable to use SD card reader
Unable to use SD card reader
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-13 14:06 EDT by Need Real Name
Modified: 2015-01-04 17:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 19:43:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (14.40 KB, text/plain)
2005-09-13 14:06 EDT, Need Real Name
no flags Details
cat /proc/iomem (1.07 KB, text/plain)
2005-09-13 14:07 EDT, Need Real Name
no flags Details
cat /proc/ioports (829 bytes, text/plain)
2005-09-13 14:07 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2005-09-13 14:06:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Epiphany/1.6.5

Description of problem:
Hello.
I have not much of an idea where to start on this one, so logging a bug.

I have a multi-card reader, and I cannot use it under Linux.

# lspci --relevant
02:0c.0 CardBus bridge: ENE Technology Inc CB-710/2/4 Cardbus Controller (rev 02)
02:0c.1 FLASH memory: ENE Technology Inc CB710 Memory Card Reader Controller

Any info on how you solved this would be great.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-09-13 14:06:37 EDT
Created attachment 118772 [details]
dmesg
Comment 2 Need Real Name 2005-09-13 14:07:02 EDT
Created attachment 118773 [details]
cat /proc/iomem
Comment 3 Need Real Name 2005-09-13 14:07:14 EDT
Created attachment 118774 [details]
cat /proc/ioports
Comment 4 Pete Zaitcev 2005-09-13 15:22:26 EDT
How does it actually look, is it a little PCB with an SD connector
which plugs in a Cardbus slot, like a normal CF adapter? Any URLs?
Comment 5 Need Real Name 2005-09-13 17:01:10 EDT
It's built into the computer, it looks like this:
 http://usa.asus.com/products/desktop/pundit/pundit_f002.jpg
(sorry for the small pic)

The PDF for the specs is here:
 http://dlsvr02.asus.com/pub/ASUS/Barebone/Pundit/manual/e1181_pundit.pdf
Page 5-2 has an annotated photo of the motherboard.
Comment 6 Dave Jones 2005-09-30 02:12:56 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 7 Need Real Name 2005-09-30 17:59:43 EDT
'fraid not. Still broken.
Comment 8 Bill Nottingham 2005-09-30 18:02:34 EDT
What is the modalias under /sys/bus/pci/devices/0000:02:0c.1 ?
Comment 9 Need Real Name 2005-09-30 18:11:30 EDT
pci:v00001524d00000510sv00001524sd00000510bc05sc01i00
Comment 10 Bill Nottingham 2005-09-30 19:36:18 EDT
OK, so that's not obviously claimed by something.

Presumably, there are no messages in dmesg if you actually plug in a card.

Out of random curiousity, I'm assuming 'modprobe wbsd nopnp=1' doesn't cause
it to magically work?

I suspect it just may be hardware that there's no driver for, yet.
Comment 11 Bill Nottingham 2005-09-30 19:43:00 EDT
In fact, some looking with Google shows there is currently no driver for this
card reader, and no specs available to write one. If the trick with wbsd doesn't
work (attempting to use the Winbond SD/MMC interface), then I'm not sure there's
really anything we can do until specs become available and the driver is
written. Sorry.
Comment 12 Need Real Name 2005-10-01 06:08:48 EDT
I tried the modprobe suggestion, but unfortunately it didn't work. dmesg stays
silent. Thanks though!

Note You need to log in before you can comment on or make changes to this bug.