Bug 168250 - up2date does not "see" multilib packages in "dir" repos
Summary: up2date does not "see" multilib packages in "dir" repos
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 4.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
: 191503 199689 (view as bug list)
Depends On:
Blocks: 191074 191079 218654
TreeView+ depends on / blocked
 
Reported: 2005-09-13 21:48 UTC by Ben Levenson
Modified: 2018-10-19 19:13 UTC (History)
4 users (show)

Fixed In Version: RHBA-2007-0250
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 22:59:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0250 normal SHIPPED_LIVE up2date bug fix update 2007-04-28 17:55:33 UTC

Description Ben Levenson 2005-09-13 21:48:29 UTC
Description of problem:
up2date ignores multilib packages when using a local "dir" directory.

Version:
up2date-4.2.57-2

To reproduce:
edit /e/s/r/sources and disable the default repo, and point up2date to the local
repo:

dir latest /opt/ia64-AS/

Note that ia64 and i386 versions of glibc are currently installed:
# rpm -q glibc
glibc-2.3.2-95.33.i686
glibc-2.3.2-95.33.ia64

Updated versions of both packages are present in my local repository:
ls /opt/ia64-AS/glibc-2*
/opt/ia64-AS/glibc-2.3.2-95.36.i686.rpm
/opt/ia64-AS/glibc-2.3.2-95.36.ia64.rpm

But up2date only sees the ia64 package:
# up2date-nox -u --dry-run glibc

Fetching Obsoletes list for channel: U6-nightly...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
glibc                                   2.3.2          95.36             ia64


Testing package set / solving RPM inter-dependencies...

Downloading headers to solve dependencies...
#######################################
Downloading headers to solve dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
glibc-2.3.2-95.33                        requires glibc-common = 2.3.2-95.33


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------

#

Comment 5 Fanny Augustin 2006-04-11 00:28:49 UTC
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release

Comment 6 Fanny Augustin 2006-04-13 19:32:20 UTC
Moving bugs to the CanFix List

Comment 7 Bret McMillan 2006-04-25 18:23:43 UTC
This looks ugly.  Looks like it's borking because on ia64, rpm.archscore('i386')
== 0, aka it's not compatible.  Therefore, up2date just chucks it out the window
as an option.

Digging deeper, looks like we're getting around this by use of a compatibility
table server-side.  Problem is, there's no server to get around the lack of an
i386 arch_compat macro when you're using a dirRepo.

Comment 8 Bret McMillan 2006-04-25 19:30:35 UTC
So, after talking more w/ alikins, I'm probably on crack... archscore isn't
always 0, depending upon hardware rev and/or emulation software.  Do you have a
system handy where archscore(i386) != 0 and it's still not seeing the i386?

Comment 11 Fanny Augustin 2006-05-08 19:08:58 UTC
This bug did not make the code freeze and it will not be fiixed during this
release cycle.  Re-aligning bug to the next release

Comment 12 Fanny Augustin 2006-05-08 20:05:07 UTC
This bug did not make the code freeze.  It will not be fixed in this releasee 
Reea ligning to the next one.

Comment 13 Doug Chapman 2006-05-17 21:23:31 UTC
*** Bug 191503 has been marked as a duplicate of this bug. ***

Comment 20 James Bowes 2006-11-09 17:15:14 UTC
Fixed in up2date-4.5.0-1

Comment 23 Bret McMillan 2006-12-08 18:12:33 UTC
*** Bug 199689 has been marked as a duplicate of this bug. ***

Comment 29 Red Hat Bugzilla 2007-05-01 22:59:38 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0250.html


Comment 31 Alexander Todorov 2007-05-23 15:41:54 UTC
Workaround is to use yum instead of up2date.
Use createrepo to create yum repository meta information.
Then add the directory containing new packages under /etc/yum.repos.d/

It was working for me on RHEL 3.8 where up2date was not working.


Note You need to log in before you can comment on or make changes to this bug.