Bug 16829 - inet_ntoa() reports successful translation for some invalid ip numbers
Summary: inet_ntoa() reports successful translation for some invalid ip numbers
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-23 22:18 UTC by John Bollinger
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-23 22:18:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Bollinger 2000-08-23 22:18:17 UTC
inet_ntoa() returns 1 (success) when called with a parameter that is just the initial
part of an IP number.  For instance, it claims to correctly convert each of "129.79.",
"129.79", and "1".  I don't know whether this is the BSD behavior, or whether it is
intended, but it at least doesn't seem to be consistent with the manual, which specifies
that the argument is an Internet host address in "standard numbers-and-dots notation."

Comment 1 Jakub Jelinek 2000-08-24 06:49:07 UTC
The standard does not specify it actually, this behaviour matches
BIND and Solaris behaviour. E.g. Irix accepts a trailing dot as well.


Note You need to log in before you can comment on or make changes to this bug.