Bug 1683018 - [cloud] "oc get cluster" doesn't work
Summary: [cloud] "oc get cluster" doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Jan Chaloupka
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-26 05:44 UTC by sunzhaohua
Modified: 2019-06-04 10:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:44 UTC

Description sunzhaohua 2019-02-26 05:44:26 UTC
Description of problem:
"oc get cluster" doesn't work

Version-Release number of selected component (if applicable):
clusterversion: 4.0.0-0.nightly-2019-02-25-234632

How reproducible:
Always

Steps to Reproduce:
1. $ oc get cluster -n openshift-machine-api
2. $ oc get clusters.machine.openshift.io -n openshift-machine-api
3. $ oc get crd

Actual results:
"oc get cluster" doesn't work. 

$ oc get cluster --all-namespaces
No resources found.

$ oc get crd
clusters.cluster.k8s.io
clusters.machine.openshift.io

$ oc get clusters.machine.openshift.io --all-namespaces
NAMESPACE               NAME           AGE
openshift-machine-api   zhsun3-hpdfk   70m

Expected results:
By default using "oc get cluster" to check cluster instead of using "oc get clusters.machine.openshift.io".

Additional info:

Comment 1 Alberto 2019-02-26 11:40:12 UTC
"oc get cluster" will show when https://github.com/openshift/machine-api-operator/pull/225 it's merged
However cluster object is for internal tooling only, we plan to remove the cluster CRD eventually and it's not advised for the user to get/manipulate it at all

Comment 2 sunzhaohua 2019-02-28 02:44:09 UTC
Verified.

$ oc get cluster
NAME           AGE
zhsun3-vkk68   14m

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-02-27-213933   True        False         7m32s     Cluster version is 4.0.0-0.nightly-2019-02-27-213933

Comment 5 errata-xmlrpc 2019-06-04 10:44:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.