Bug 168305 - klipper-kde31.sh update script overwrites user preference
klipper-kde31.sh update script overwrites user preference
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kdebase (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-14 14:51 EDT by Robert Minsk
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 09:43:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Minsk 2005-09-14 14:51:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050910 CentOS/1.0.6-1.4.2.centos4 Firefox/1.0.6

Description of problem:
/usr/share/apps/kconf_update/klipper-kde31.sh will overwrite AutoStart.  The update script only looks for Hidden=true in the users config file and if it does not find it it will explicitly set AutoStart=true.  The problem is that our users already had AutoStart=false in there config files and since the script only checks for Hidden the users AutoStart was being overwritten.

Currently klipper-kde31.sh is:
#!/bin/sh
filename=`kde-config --localprefix`share/autostart/klipper.desktop
if grep 'Hidden=true' "$filename" > /dev/null 2> /dev/null; then
  echo AutoStart=false
else
  echo AutoStart=true
fi
rm -f "$filename"

it should be changed to:
#!/bin/sh
filename=`kde-config --localprefix`share/autostart/klipper.desktop
if grep 'Hidden=true' "$filename" > /dev/null 2> /dev/null; then
  echo AutoStart=false
fi
rm -f "$filename"

This does not cause a problem since /usr/share/autostart/klipper.desktop already defaults to true.


Version-Release number of selected component (if applicable):
kdebase-3.3.1-5.5

How reproducible:
Always

Steps to Reproduce:
1. See above description

  

Additional info:
Comment 1 Ngo Than 2006-05-24 09:43:57 EDT
it's fixed in rawhide and the upcomming RHEL5 will include the fix. Thanks

Note You need to log in before you can comment on or make changes to this bug.