Bug 1683061 - SSCS: Ensure customers can manually rotate SSCS certs and SSCS CA
Summary: SSCS: Ensure customers can manually rotate SSCS certs and SSCS CA
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Matt Rogers
QA Contact: Chuan Yu
URL:
Whiteboard:
: 1611823 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-26 08:02 UTC by Chuan Yu
Modified: 2019-06-04 10:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:44 UTC

Description Chuan Yu 2019-02-26 08:02:15 UTC
Per: https://jira.coreos.com/browse/AUTH-189

Comment 1 Neelesh Agrawal 2019-03-07 14:54:29 UTC
*** Bug 1611823 has been marked as a duplicate of this bug. ***

Comment 3 Erica von Buelow 2019-04-17 13:05:03 UTC
https://github.com/openshift/service-ca-operator/pull/42

Comment 4 Neelesh Agrawal 2019-04-29 14:43:57 UTC
The PR in Comment#3 will be covered in 4.2. Manual rotation

Comment 5 Neelesh Agrawal 2019-04-29 14:45:53 UTC
...Manual rotation works and tested. Closing the bug. Making this modified, so, QE can verify this manual procedure. There is an e2e test covering this too.

Comment 7 Chuan Yu 2019-04-30 00:34:46 UTC
Verified.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-04-28-064010   True        False         22h     Cluster version is 4.1.0-0.nightly-2019-04-28-064010

Comment 9 errata-xmlrpc 2019-06-04 10:44:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.