Bug 1683089 - Failed to load plugin Pipeline for Blue Ocean in jenkins pod logs
Summary: Failed to load plugin Pipeline for Blue Ocean in jenkins pod logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Gabe Montero
QA Contact: wewang
URL:
Whiteboard:
: 1683127 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-26 09:04 UTC by XiuJuan Wang
Modified: 2019-06-04 10:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:44 UTC

Description XiuJuan Wang 2019-02-26 09:04:52 UTC
Description of problem:
There are some error logs about plugin Pipeline for Blue Ocean v1.10.2 in jenkins server logs.
Finally the jenkins pod could be running

Version-Release number of selected component (if applicable):

quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:492c935fd6d53e3a02657f8785070cd93a036899a2779daab8dc4e11b3d1924d
name=openshift/ose-jenkins
release=0.183.0.0
version=v4.0.0

How reproducible:
always

Steps to Reproduce:
1.Create a jenkins server
$oc new-app jenkins-persistent
2.Check jenkins logs


Actual results:
INFO: Listed all plugins
Feb 26, 2019 8:37:13 AM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin Pipeline implementation for Blue Ocean v1.10.2 (blueocean-pipeline-api-impl)
java.io.IOException: Pipeline implementation for Blue Ocean v1.10.2 failed to load.
 - Pipeline: Nodes and Processes v2.22 is older than required. To fix, install v2.26 or later.
	at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:652)
	at hudson.PluginManager$2$1$1.run(PluginManager.java:517)
	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)
	at jenkins.model.Jenkins$5.runTask(Jenkins.java:1083)
	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)
	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Feb 26, 2019 8:37:13 AM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin Bitbucket Pipeline for Blue Ocean v1.10.2 (blueocean-bitbucket-pipeline)
java.io.IOException: Bitbucket Pipeline for Blue Ocean v1.10.2 failed to load.
 - Pipeline implementation for Blue Ocean v1.10.2 failed to load. Fix this plugin first.
	at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:652)
	at hudson.PluginManager$2$1$1.run(PluginManager.java:517)
	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)
	at jenkins.model.Jenkins$5.runTask(Jenkins.java:1083)
	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)
	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Feb 26, 2019 8:37:13 AM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin Events API for Blue Ocean v1.10.2 (blueocean-events)
java.io.IOException: Events API for Blue Ocean v1.10.2 failed to load.
 - Pipeline implementation for Blue Ocean v1.10.2 failed to load. Fix this plugin first.
	at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:652)
	at hudson.PluginManager$2$1$1.run(PluginManager.java:517)
	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)
	at jenkins.model.Jenkins$5.runTask(Jenkins.java:1083)
	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)
	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Feb 26, 2019 8:37:13 AM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin GitHub Pipeline for Blue Ocean v1.10.2 (blueocean-github-pipeline)
java.io.IOException: GitHub Pipeline for Blue Ocean v1.10.2 failed to load.
 - Pipeline implementation for Blue Ocean v1.10.2 failed to load. Fix this plugin first.
	at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:652)
	at hudson.PluginManager$2$1$1.run(PluginManager.java:517)
	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)
	at jenkins.model.Jenkins$5.runTask(Jenkins.java:1083)
	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)
	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Feb 26, 2019 8:37:13 AM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin Git Pipeline for Blue Ocean v1.10.2 (blueocean-git-pipeline)
java.io.IOException: Git Pipeline for Blue Ocean v1.10.2 failed to load.
 - Pipeline implementation for Blue Ocean v1.10.2 failed to load. Fix this plugin first.
	at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:652)
	at hudson.PluginManager$2$1$1.run(PluginManager.java:517)
	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)
	at jenkins.model.Jenkins$5.runTask(Jenkins.java:1083)
	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)
	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Feb 26, 2019 8:37:13 AM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin JIRA Integration for Blue Ocean v1.10.2 (blueocean-jira)
java.io.IOException: JIRA Integration for Blue Ocean v1.10.2 failed to load.
 - Jenkins JIRA plugin v3.0.2 is older than required. To fix, install v3.0.5 or later.
	at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:652)
	at hudson.PluginManager$2$1$1.run(PluginManager.java:517)
	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)
	at jenkins.model.Jenkins$5.runTask(Jenkins.java:1083)
	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)
	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Feb 26, 2019 8:37:13 AM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin Blue Ocean Pipeline Editor v1.10.2 (blueocean-pipeline-editor)
java.io.IOException: Blue Ocean Pipeline Editor v1.10.2 failed to load.
 - Pipeline implementation for Blue Ocean v1.10.2 failed to load. Fix this plugin first.
	at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:652)
	at hudson.PluginManager$2$1$1.run(PluginManager.java:517)
	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)
	at jenkins.model.Jenkins$5.runTask(Jenkins.java:1083)
	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)
	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Feb 26, 2019 8:37:13 AM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin Blue Ocean v1.10.2 (blueocean)
java.io.IOException: Blue Ocean v1.10.2 failed to load.
 - Bitbucket Pipeline for Blue Ocean v1.10.2 failed to load. Fix this plugin first.
	at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:652)
	at hudson.PluginManager$2$1$1.run(PluginManager.java:517)
	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:296)
	at jenkins.model.Jenkins$5.runTask(Jenkins.java:1083)
	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:214)
	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)



Expected results:
Should no error in jenkins logs

Additional info:
Also there are
"Downstream dependency errors" in Manage jenkins page.

Comment 1 Gabe Montero 2019-02-26 15:08:20 UTC
this has happened before .... jenkins changing the deps for their plugins without bumping the versions of those plugins

I'll have to see if I can repro this with the latest ... if not, I may need help getting at the specific version 
is getting at with quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:492c935fd6d53e3a02657f8785070cd93a036899a2779daab8dc4e11b3d1924d,
so some more specific details around prior use of the PV jenkins was using (i.e. did it have stale plugins on it).

Comment 2 Gabe Montero 2019-02-26 15:58:12 UTC
So the origin version of the jenkins image is correct, but https://buildvm.openshift.eng.bos.redhat.com:8443/job/devex/job/devex%252Fjenkins-plugins/102/ introduced a regression from 2.26 to 2.22 for ocp 

https://buildvm.openshift.eng.bos.redhat.com:8443/job/devex/job/devex%252Fjenkins-plugins/101/ had specified 2.26

Of course our jenkins build/pr flows have been in flux lately, and this looks a bug in my new plugin lister.

Investigating.

Comment 3 Gabe Montero 2019-02-26 16:05:29 UTC
Actually not a bug in the lister ... the upstream deps did change such that the plugin downloader the new lister calls does not req 2.26 anymore

will change the version lock in our plugin file to address

Comment 4 Gabe Montero 2019-02-26 16:18:08 UTC
PR https://github.com/openshift/jenkins/pull/806 is up

Comment 5 Gabe Montero 2019-02-26 20:11:09 UTC
the RPM is updated at dist git http://pkgs.devel.redhat.com/cgit/rpms/jenkins-2-plugins/commit/?h=rhaos-4.0-rhel-7&id=11d3dcd20c9fd5c6d65b02e6aca6e3b95489d5e6

The PR is still waiting on one more test to pass but in theory once an ocp jenkins image is built with this RPM commit (in theory separate from the PR image build)
we should be good to go.

That said, I'll give the PR a bit more time before moving to QA

Comment 6 Gabe Montero 2019-02-26 21:15:12 UTC
PR has merged as well

Comment 7 wewang 2019-02-27 08:10:41 UTC
Tested origin jenkins image from:
 registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-02-26-194020@sha256:a77c9263cca1d76fd296efcc8c5219202d80a07371edc0f81e64a896c18e4eca, when create apps with jenkins-persistent,no error info and  workflow-durable-task-step is 2.26

Tested ocp jenkins image from latest payload:
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:41e80f197daa9bc7e5504fba998f9c697f74de3017661e708e0e19e0e0fbaa81, still had error, and workflow-durable-task-step is 2.22, when newer payload is coming, will verify it

Comment 8 XiuJuan Wang 2019-02-27 10:05:25 UTC
Could verify this bug with registry.svc.ci.openshift.org/ocp/release:4.0.0-0.ci-2019-02-27-042726 payload
and the jenkins image
registry.svc.ci.openshift.org/ocp/4.0-2019-02-27-042750@sha256:466f38fd4218bc3d203411bb47dd815b12ca24e11fc735dc64b5fc872b3e2ae3

Comment 9 XiuJuan Wang 2019-02-27 11:19:09 UTC
*** Bug 1683127 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2019-06-04 10:44:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.