Bug 168319 - tetex - nasty configuration surprise
tetex - nasty configuration surprise
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-14 17:53 EDT by Michal Jaegermann
Modified: 2013-07-02 19:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 06:47:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-09-14 17:53:22 EDT
Description of problem:

After installing tetex-3.0-4 I got complaints from my users that something
is wrong with configuration.  Pages are positioned badly on a printout,
hyphenation is not loaded as expected, ...  This despite that I run
'texconfig' and it looked that things were ok.

Digging around revealed that 'texconfig' used by root does not adjust
a system-wide configuration any longer but it writes various files in
/root/.texmf-config/ and /root/.texmf-var/ and this obviously cannot
set system-wide defaults - like a paper size.  If there is some warning
about this drastic behaviour change I missed it and quick tests run while
installing things did not reveal, obviously, anything amiss.  I wasted
quite a while before I caught what is really happening.

It is nice that users can adjust things on an account-by-account basis
but 'root' is special and _forcing_ users to do things which they may
not fully understand/appreciate is not so nice any longer.

To restore the previous texconfig behaviour one can simply make
/root/.texmf-config and /root/.texmf-var into symbolic links to 
/usr/share/texmf and /usr/share/texmf-var respectively; but now these
directories may actually exist and things are becoming messy.  Sigh!

Version-Release number of selected component (if applicable):
tetex-3.0-4
Comment 1 Jindrich Novy 2005-10-31 06:47:16 EST
Maybe the message:
http://article.gmane.org/gmane.comp.tex.tetex.general/952

and a reply from Thomas Esser:
http://article.gmane.org/gmane.comp.tex.tetex.general/954

will be of some help here. Looks like some env variables need to be setup first.
It's unlikely that the symlinks you've done are needed any more then.

This looks more like a problem to be resolved upstream than here. So maybe you
can go on with the thread and discuss this problem on the list directly with
Thomas Esser. I'm on the list too, so as soon as a solution is found I can fix
stuff in FC teTeX as well.
Comment 2 Michal Jaegermann 2005-10-31 23:34:52 EST
I guess that I will post something about that a tetex mailing list once I will
figure out how to do that.  I gather from quoted messages that not env variables
are needed but one should now to use different utilities to tetex system wide.
Namely texconfig-sys and possibly fmtutil-sys.

These may work all right but that clearly violates a principle of the least
surprise.  Those who for years knew that texconfig is a proper and reasonable
way to create system default settings are bound to be surprised even if
TETEXDOC.pdf happens to mention texconfig-sys (assuming that one looks at the
right version).  A prominent warning when texconfig is run from a root account
that most likely this is not doing what one think that it may be doing and
chances are that you want and possibly texconfig-sys should be used instead.
Comment 3 Jindrich Novy 2005-11-01 03:19:32 EST
Yes, tetex@dbs.uni-hannover.de is the right place to complain about user-space
teTeX-3 problems. This is the official teTeX mailing list. You can subscribe to
the list from http://www.tug.org/teTeX/.

Note You need to log in before you can comment on or make changes to this bug.