Bug 1683375 - Fedora Flatpak applications are randomly missing their icons
Summary: Fedora Flatpak applications are randomly missing their icons
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: flatpak
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/flatpak/flatpak/pu...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-26 17:44 UTC by Daniel Rusek
Modified: 2019-08-20 01:48 UTC (History)
7 users (show)

Fixed In Version: flatpak-1.4.2-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-20 01:48:44 UTC
Type: Bug


Attachments (Terms of Use)
GNOME Software main page - empty icons of Audacity and FeedReader (120.16 KB, image/png)
2019-02-26 17:44 UTC, Daniel Rusek
no flags Details

Description Daniel Rusek 2019-02-26 17:44:50 UTC
Created attachment 1538927 [details]
GNOME Software main page - empty icons of Audacity and FeedReader

Description of problem:
Icons for some applications seem to be missing in GNOME Software on Fedora Silverblue Rawhide. For example rpm-ostree Audacity or FeedReader from the Fedora Flatpak repo.

Version-Release number of selected component (if applicable):
gnome-software-3.31.90-1.fc31.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Use latest Fedora Silverblue Rawhide system with Fedora Flatpak repository added.
2. Open GNOME Software.
3. Search for "FeedReader".

Actual results:
FeedReader icon is empty.

Expected results:
FeedReader has correct icon.

Additional info:
See the attached screenshot.

Comment 1 Kalev Lember 2019-02-28 12:28:08 UTC
Owen, it looks like the fedora testing flatpak repo doesn't have any icons in the appstream metadata. Do you know what's going wrong there?

Comment 2 Daniel Rusek 2019-06-21 09:40:33 UTC
Apps from the fedora Flatpak repo still seem to have no icons.

Comment 3 Daniel Rusek 2019-06-21 19:48:47 UTC
Hmm, the icons seem to be correctly displayed on a regular Fedora 30, but missing on Fedora Silverblue Rawhide. Not sure what is going on.

Comment 4 Daniel Rusek 2019-07-08 10:48:07 UTC
Ignore my previous comment. Not sure what I was looking at, but I re-checked it now on multiple Fedora machines and it seems that the icons of most apps from Fedora Flatpak repo are missing on a regular Fedora 30 as well. Some apps, however, have correct icon on both Fedora 30 and Silverblue Rawhide, for example Tilix.

Comment 5 Daniel Rusek 2019-07-30 21:08:05 UTC
Hmm, it seems that the icons are randomly displayed and missing in GNOME Software. I have checked this on multiple Fedora machines and icons for some apps from the Fedora Flatpak repo were correctly displayed on some machines, but missing on other machines and it was quite random - for example on one machine, the icon for Fedora Flatpak version of GNOME Chess was correctly displayed, but the icon for Fedora Flatpak version of Firefox was missing while on other machine, the icon for Fedora Flatpak version of GNOME Chess was missing, but the icon for Fedora Flatpak version of Firefox was correctly displayed and on another machine, both icons were missing.

Comment 6 Daniel Rusek 2019-07-31 15:22:20 UTC
This seems to be in the GS log, for example when browsing the Games section:

15:20:50:0608 Gs  failed to load icon for com.play0ad.zeroad: Failed to open file ?/var/lib/flatpak/appstream/fedora/x86_64/icons/64x64/com.play0ad.zeroad.png?: No such file or directory
15:20:50:0608 Gs  failed to load icon for org.gnome.Aisleriot: Failed to open file ?/var/lib/flatpak/appstream/fedora/x86_64/icons/64x64/org.gnome.Aisleriot.png?: No such file or directory
15:20:50:0608 Gs  failed to load icon for org.gnome.Chess: Failed to open file ?/var/lib/flatpak/appstream/fedora/x86_64/icons/64x64/org.gnome.Chess.png?: No such file or directory
15:20:50:0608 Gs  failed to load icon for org.gnome.Mahjongg: Failed to open file ?/var/lib/flatpak/appstream/fedora/x86_64/icons/64x64/org.gnome.Mahjongg.png?: No such file or directory
15:20:50:0608 Gs  failed to load icon for org.gnome.Tetravex: Failed to open file ?/var/lib/flatpak/appstream/fedora/x86_64/icons/64x64/org.gnome.Tetravex.png?: No such file or directory
15:20:50:0608 Gs  failed to load icon for org.gnome.Quadrapassel: Failed to open file ?/var/lib/flatpak/appstream/fedora/x86_64/icons/64x64/org.gnome.Quadrapassel.png?: No such file or directory
15:20:50:0608 Gs  failed to load icon for org.supertuxproject.SuperTux: Failed to open file ?/var/lib/flatpak/appstream/fedora/x86_64/icons/64x64/org.supertuxproject.SuperTux.png?: No such file or directory
15:20:50:0608 Gs  failed to load icon for net.sourceforge.torcs: Failed to open file ?/var/lib/flatpak/appstream/fedora/x86_64/icons/64x64/net.sourceforge.torcs.png?: No such file or directory
15:20:50:0608 Gs  failed to load icon for net.warsow.Warsow: Failed to open file ?/var/lib/flatpak/appstream/fedora/x86_64/icons/64x64/net.warsow.Warsow.png?: No such file or directory
15:20:50:0608 Gs  failed to load icon for org.wesnoth.Wesnoth: Failed to open file ?/var/lib/flatpak/appstream/fedora/x86_64/icons/64x64/org.wesnoth.Wesnoth.png?: No such file or directory

Comment 7 Michal Konecny 2019-08-06 17:33:11 UTC
I can confirm that this is happening at random.

gnome-software 3.32.4

Comment 8 Owen Taylor 2019-08-07 16:08:53 UTC
This is similar to https://github.com/flatpak/flatpak/issues/2835 - but that should be fixed on F30 now.

 Daniel and Michal - can you confirm that you have flatpak-1.4 ?

With the fix for 2835, there's still a possibility you would get this if there was a network failure during an update.

Can you check:

 sudo rm /var/lib/flatpak/appstream/fedora/x86_64/.timestamp /var/lib/flatpak/oci/fedora.index.gz
 flatpak update --appstream fedora

Does that fix? If not, what errors do you have in your journalctl logs?

Comment 9 Daniel Rusek 2019-08-07 17:54:35 UTC
Owen,

$ rpm -q flatpak
flatpak-1.4.2-4.fc31.x86_64

The provided workaround from your comment didn't fix the issue.

I have tried it with gnome-software-3.32.4-2.fc31.x86_64 and latest gnome-software from Git master and there was the same issue on both versions.

Comment 10 Owen Taylor 2019-08-07 18:00:52 UTC
(In reply to Daniel Rusek from comment #9)
> Owen,
> 
> $ rpm -q flatpak
> flatpak-1.4.2-4.fc31.x86_64
> 
> The provided workaround from your comment didn't fix the issue.

Not so much a workaround as for debugging :-)

 * Did those commands produce any relevant looking output in journalctl?
 * Is the missing icon in /var/lib/flatpak/appstream/fedora/x86_64/icons/ ? 
 * If the icon is there, what if you kill all gnome-software processes and start it again?

Comment 11 Daniel Rusek 2019-08-07 19:50:47 UTC
Owen,

1.) This was in journalctl:

srp 07 21:38:11 virt-silverblue flatpak-system-helper[2147]: bijiben: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:11 virt-silverblue flatpak-system-helper[2147]: bijiben: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:11 virt-silverblue flatpak-system-helper[2147]: cheese: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:11 virt-silverblue flatpak-system-helper[2147]: cheese: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:11 virt-silverblue flatpak-system-helper[2147]: darktable: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:11 virt-silverblue flatpak-system-helper[2147]: darktable: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: devhelp: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: devhelp: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: eog: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: eog: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: firefox: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: firefox: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gedit: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gedit: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: ghex: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: ghex: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gimp: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gimp: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gitg: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gitg: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: glade: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: glade: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-calculator: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-calculator: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-characters: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-characters: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-chess: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-chess: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-font-viewer: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-font-viewer: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-logs: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-logs: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-mahjongg: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-mahjongg: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-maps: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-maps: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-screenshot: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-screenshot: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-sound-recorder: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-sound-recorder: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-tetravex: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:12 virt-silverblue flatpak-system-helper[2147]: gnome-tetravex: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:14 virt-silverblue flatpak-system-helper[2147]: meld: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:14 virt-silverblue flatpak-system-helper[2147]: meld: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:14 virt-silverblue flatpak-system-helper[2147]: supertux: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:14 virt-silverblue flatpak-system-helper[2147]: supertux: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:15 virt-silverblue flatpak-system-helper[2147]: transmission: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:15 virt-silverblue flatpak-system-helper[2147]: transmission: Failed to add 128x128 icon: Reusing cached value
srp 07 21:38:15 virt-silverblue flatpak-system-helper[2147]: wesnoth: Failed to add 64x64 icon: Reusing cached value
srp 07 21:38:15 virt-silverblue flatpak-system-helper[2147]: wesnoth: Failed to add 128x128 icon: Reusing cached value

2.) The missing icons are not in /var/lib/flatpak/appstream/fedora/x86_64/icons/.

3.) I have tried killing gnome-software several times to test if 0 A.D. icon that was correctly displayed in GNOME Software and present in /var/lib/flatpak/appstream/fedora/x86_64/icons/ will be still there - it was.

Comment 12 Daniel Rusek 2019-08-07 19:58:51 UTC
So it seems that this is most likely not a GNOME Software issue. Feel free to switch this bz to flatpak.

Comment 13 Owen Taylor 2019-08-07 20:20:26 UTC
If you look at those blocks of errors in your logs, you'll see what happens is that it switches from erroring on one-half of the icons, to erroring on the other half of the icons. :-(

What's happening is that the code
 
 - Loops through icons:
   - When icons are successfully downloaded, the are marked as used
     - But "already cached, don't need to download" is handled as an error, and the icon isn't marked as used
 - Deletes all unused icons

So when we download icons we download everything we didn't have, and delete everything we did have....

(I have this problem locally, but didn't notice because the app that I spot-checked was in the currently downloaded block, and when I forced things to re-download, still had icons - I didn't notice they were different icons!)

Thanks for the testing! Will PR upstream and get a fix into Fedora.

Comment 14 Owen Taylor 2019-08-07 20:58:22 UTC
Daniel - can you see if you can 'rpm-ostree override replace' flatpak / flatpak-session-helper from the scratch build:

 https://koji.fedoraproject.org/koji/taskinfo?taskID=36850768

(Once that completes) - and see if that fixes the problem. I'm having weird rpm-ostree problems on F30 because of the addition of flatpak-session-helper subpackage (I think!) but it sounds like you are running rawhide.

Comment 15 Daniel Rusek 2019-08-07 21:26:32 UTC
Owen,

I am unfortunately not able to override the packages:

error: Base packages would be removed: selinux-policy-targeted-3.14.4-28.fc31.noarch

Comment 16 Owen Taylor 2019-08-08 14:35:16 UTC
(In reply to Daniel Rusek from comment #15)
> I am unfortunately not able to override the packages:
> 
> error: Base packages would be removed:
> selinux-policy-targeted-3.14.4-28.fc31.noarch

Doing an 'rpm-ostree update' first might help.

In any case, I managed to get the change tested here, and built it for rawhide, so with luck, the fix will be in tomorrow's compose.

Comment 17 Daniel Rusek 2019-08-12 09:42:14 UTC
I was finally able to test this. The issue seems to be fixed. Thanks!

Comment 18 Ben Cotton 2019-08-13 17:04:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 19 Ben Cotton 2019-08-13 17:08:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 20 Fedora Update System 2019-08-15 09:33:35 UTC
FEDORA-2019-443d67d669 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-443d67d669

Comment 21 Fedora Update System 2019-08-16 19:50:45 UTC
flatpak-1.4.2-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-443d67d669

Comment 22 Fedora Update System 2019-08-20 01:48:44 UTC
flatpak-1.4.2-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.