Bug 1683462 - Usage of CPU limits in pods that run on masters
Summary: Usage of CPU limits in pods that run on masters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Brad Ison
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-26 22:15 UTC by Derek Carr
Modified: 2019-06-04 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:45 UTC

Description Derek Carr 2019-02-26 22:15:42 UTC
Description of problem:

Usage of cpu limits is not recommended for cluster managed components as it introduces unnecessary latency, and in general, we can depend on CFS sharing enforced via cpu requests to get proper sharing of cpu time.

An e2e test in origin is attempting to enforce that we maintain this restriction here: https://github.com/openshift/origin/pull/22095

Invalid control plane pods (namespace/pod/container) found with cpu resource limits set 

openshift-machine-api/cluster-autoscaler-operator-db68b67dc-m6r5t/cluster-autoscaler-operator
openshift-machine-api/machine-api-operator-6ccdbc5f6f-27pg7/machine-api-operator
openshift-machine-config-operator/machine-config-controller-85988d695b-zzgkt/machine-config-controller


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Brad Ison 2019-02-28 08:51:05 UTC
cluster-autoscaler-operator: https://github.com/openshift/cluster-autoscaler-operator/pull/58
machine-api-operator: https://github.com/openshift/machine-api-operator/pull/228

The machine-config-operator does not belong to the Cloud component.

Comment 4 Jianwei Hou 2019-03-07 09:57:49 UTC
Verified with 4.0.0-0.nightly-2019-03-07-075403, I've extracted the release-payload and confirmed the CPU limits are removed.

Comment 7 errata-xmlrpc 2019-06-04 10:44:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.