Bug 168363 - Poor SATA performance (libata / ata_piix) with ICH5 chipset
Poor SATA performance (libata / ata_piix) with ICH5 chipset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 09:05 EDT by Thomas M Steenholdt
Modified: 2013-07-02 22:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 23:23:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from lspci -vvv (10.00 KB, text/plain)
2005-09-15 09:08 EDT, Thomas M Steenholdt
no flags Details
output from lsmod (1.95 KB, text/plain)
2005-09-15 09:08 EDT, Thomas M Steenholdt
no flags Details

  None (edit)
Description Thomas M Steenholdt 2005-09-15 09:05:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050914 Fedora/1.5b1-0.fc3 Firefox/1.4

Description of problem:
Somewhere between kernel-smp-2.6.11-1.1369_FC4 and kernel.smp-2.6.13-1.1542_FC5, my SATA disk changed device name from sda to hda and performance of the disk got reduced from ~56MB/sec (hdparm -t) to ~3MB/sec (best scenario).

Performance hasn't improved in kernel-smp-2.6.13-1.1553_FC5.

A little might-be interesting snip from dmesg :
---
SCSI subsystem initialized
libata version 1.12 loaded.
ata_piix version 1.04
ata_piix: combined mode detected
ACPI: PCI Interrupt 0000:00:1f.2[A] -> GSI 18 (level, low) -> IRQ 169
ata: 0x1f0 IDE port busy
ata: 0x170 IDE port busy
ata_piix: probe of 0000:00:1f.2 failed with error -16
---

i'll attach output from lspci -vvv and lsmod in the hope that it'll give you guys something to work with. 

Does this all make sense to you?

Version-Release number of selected component (if applicable):
kernel-smp-2.6.13-1.1553_FC5

How reproducible:
Always

Steps to Reproduce:
1. Boot a kernel higher than kernel-smp-2.6.13-1.1542_FC5 (possibly earlier version had this too)
2. run hdparm -t /dev/hda
3. prepare to be amazed (in the bad way)
  

Actual Results:  ~3 MB/sec 

Expected Results:  ~55MB/sec

Additional info:

strace -c dd if=/dev/zero of=testfile bs=1M count=100 sometimes show very slow calls to open and/or write... an example :

usecs/call (open): >1600000 (and so spends 20 secs just opening - but this does not happen every time).

strace -c hdparm -t /dev/hda shows long read times, often > 120000 usecs/call.
Comment 1 Thomas M Steenholdt 2005-09-15 09:08:06 EDT
Created attachment 118844 [details]
output from lspci -vvv
Comment 2 Thomas M Steenholdt 2005-09-15 09:08:42 EDT
Created attachment 118845 [details]
output from lsmod
Comment 3 Thomas M Steenholdt 2005-09-21 17:48:10 EDT
adding kernel command line args :

ide0=noprobe ide1=noprobe

switches behaviour back to earlier kernels. I still get the ioctl errors, but
the performance is as expected!

This must be a chipset detection problem or..?
Comment 4 Rodd Clarkson 2005-09-21 19:43:37 EDT
I've seen the same behavior on up kernels too.

FC4 kernels see my hdd as /dev/sda and my DVD-RW as /dev/hdc
FC5 kernels (started at some point) to see my HDD as /dev/hda and DVD-RW as /dev/hdc

Performance on the DVD isn't that much different (and is incapable of playing a
DVD or burned a CD at full speed), but performance of the HDD is really poor
(was ~30MB/s, now ~2.5MB/s)

I'm using the ICH6M chipset.
Comment 5 Thomas M Steenholdt 2005-09-23 08:56:56 EDT
On my system (an IBM ThinkCentre 8194-7JG), chnaging the IDE controller's
"Native Mode" setting from "Automatic" to "Serial ATA" made a world of
differende. I no longer need the noprobe options, my SATA disk is rightly
detected as such and performs as I would expect it to.

This still qualifies as a kernel bug, though, right? Since it works in the FC4
kernel or is there an reason for all this???
Comment 6 Simon Roberts 2005-10-16 03:24:42 EDT
Same issue here. Machine is a new Dell Inspiron 9300 (ICH6).  With stock
kernel-2.6.12-1.1456_FC4 disk performance is okay (30 MB/s), but I can't enable
DMA on the DVD-rom. If I rebuild the kernel with ATA_ENABLE_ATAPI and
ATA_ENABLE_PATA libata.h, both are okay.

With kernel-2.6.13-1.1526_FC4 (even with the patch above) I get slow <3 MB/s
performance.  Obviously a problem.
Comment 7 Simon Roberts 2005-10-16 03:46:45 EDT
"hda=noprobe ide0=noprobe ide1=noprobe" (hey, the more the merrier) put
performance back to what it was previously.
Comment 8 Simon Roberts 2005-10-21 06:54:27 EDT
A few reboots later - now performance is back to sucky.  Is it random? 
Comment 9 Simon Roberts 2005-10-21 08:49:58 EDT
Just tried with kernel-2.6.13-1.1532_FC4, and it's all good!  No "noprobe" junk
required (for harddisk performance at least)
Comment 10 Rodd Clarkson 2005-11-03 22:53:44 EST
Just removed ide0=noprobe and things are working really well for me too.

I think we could close this bug as resolved.

Note You need to log in before you can comment on or make changes to this bug.