Bug 168370 - applet fails to notify user about failed jobs
Summary: applet fails to notify user about failed jobs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 8
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9Target
TreeView+ depends on / blocked
 
Reported: 2005-09-15 14:24 UTC by John Levon
Modified: 2008-03-03 17:33 UTC (History)
0 users

Fixed In Version: 0.7.82.1-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 17:33:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PostScript file that crashes ijs gimp print (1.42 MB, application/octet-stream)
2005-09-15 14:44 UTC, John Levon
no flags Details
CUPS error log (15.09 KB, text/plain)
2005-09-24 11:55 UTC, John Levon
no flags Details

Description John Levon 2005-09-15 14:24:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8b4) Gecko/20050717 Firefox/1.0+

Description of problem:
Running ijsgimpprint via kprinter from an acroread generated PS file, the dmesg
gives:

ijsgimpprint[32022]: segfault at 0000000000000018 rip 00000031ab145cd5 rsp 00007fffffe14798 error 4

I'm attaching the PS file. PDF file on request. Using xpdf works.

I can't find out where it's dumping core though. I set ulimit -c unlimited in the same shell and restarted cupsd and printed again, but still no idea where the core might be. Suggestions?

Version-Release number of selected component (if applicable):
gimp-print-4.2.7-7

How reproducible:
Always

Steps to Reproduce:
1. use kprinter on the attached PS file
2. watch dmesg for the crash
  

Actual Results:  Crashed

Expected Results:  Printed

Additional info:

It's printing to an Epson RX420 using the RX500 driver backend. Other things are printing fine, so it's obviously something dubious in the PostScript in gimp-print's eyes.

Comment 1 John Levon 2005-09-15 14:44:03 UTC
Created attachment 118854 [details]
PostScript file that crashes ijs gimp print

Comment 2 Tim Waugh 2005-09-19 14:01:37 UTC
Please edit /etc/cups/cupsd.conf so that the "LogLevel" line reads:

LogLevel debug2

Then run these commands:

/sbin/service cups stop
>/var/log/cups/error_log
/sbin/service cups start

Submit the print job again, and when it fails please attach the
/var/log/cups/error_log file.

Comment 3 John Levon 2005-09-24 11:55:00 UTC
Created attachment 119223 [details]
CUPS error log

Comment 4 Tim Waugh 2005-09-27 11:22:36 UTC
This looks like the error:

D [24/Sep/2005:12:54:13 +0000] [Job 23] Error: /invalidfont in -dict-
D [24/Sep/2005:12:54:13 +0000] [Job 23] Operand stack:
D [24/Sep/2005:12:54:13 +0000] [Job 23] OFCJPE+StarSymbol-Identity-H  
--dict:7/10(G)--   Font   OFCJPE+StarSymbol-Identity-H   --dict:7/10(G)--  
OFCJPE+StarSymbol-Identity-H
D [24/Sep/2005:12:54:13 +0000] [Job 23] Execution stack:
D [24/Sep/2005:12:54:13 +0000] [Job 23] %interp_exit   .runexec2  
--nostringval--   --nostringval--   --nostringval--   2   %stopped_push  
--nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push
  1   3   %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   1   3  
%oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostringval-- 
 2   %stopped_push
 --nostringval--   3   8   %oparray_pop   3   8   %oparray_pop   --nostringval--
  --nostringval--   --nostringval--   7   9   %oparray_pop   --nostringval--
7   9   %oparray_pop   --nostringval--   --nostringval--
D [24/Sep/2005:12:54:13 +0000] [Job 23] Dictionary stack:
D [24/Sep/2005:12:54:13 +0000] [Job 23] --dict:1079/1123(ro)(G)--  
--dict:0/20(G)--   --dict:78/200(L)--   --dict:36/89(L)--  
--dict:76/160(ro)(L)--   --dict:63/78(ro)(L)--   --dict:8/25(L)--  
--dict:27/35(ro)(L)--   --dict:17/17(ro)(G)--
D [24/Sep/2005:12:54:13 +0000] [Job 23] Current allocation mode is local
D [24/Sep/2005:12:54:13 +0000] [Job 23] Last OS error: 2
D [24/Sep/2005:12:54:13 +0000] [Job 23] GNU Ghostscript 7.07: Unrecoverable
error, exit code 1

What about the 'dmesg' messages you mentioned?  Could you paste them in please?

Comment 5 Tim Waugh 2005-09-27 11:23:30 UTC
Oh, sorry, it was just the one message and you already included it..

Comment 6 Tim Waugh 2005-09-27 11:31:05 UTC
Okay, it looks to me as though the segfault is harmless and not causing the file
to be impossible to print.

In particular, this /invalidfont message is also seen from 'evince a.ps' for me.
 Perhaps you need to embed the fonts you are using into the PostScript file.

Comment 7 John Levon 2005-09-27 13:34:33 UTC
Wow. Two bugs, and you WONTFIX?

First, a segfault in RH-supplied code is NEVER not a bug, regardless of
how harmless it is. Feel free to assign priority appropriately, but it is a bug.

Second, the lack of any useful feedback. I would at least expect a syslog
message. If it worked like it should, I would get something back from KDE too.

Comment 8 Tim Waugh 2005-09-27 14:40:59 UTC
gimp-print will soon be replaced by Gutenprint.  In any case, fixing a crash
that only happens when ghostscript has decided the job is unprintable is always
going to be low priority.

As for feedback: you get the error_log message, and perhaps eggcups ought to
notify you of failed jobs.

Comment 9 John Levon 2005-09-27 16:03:09 UTC
> low priority

That's fine, thanks.

>  eggcups ought to notify you of failed jobs

That would certainly fix the issue.

Comment 10 Christian Iseli 2007-01-22 11:04:04 UTC
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.

Comment 11 Tim Waugh 2008-02-27 11:55:14 UTC
Moving to system-config-printer.  The applet needs to notify about failed jobs.


Note You need to log in before you can comment on or make changes to this bug.