Bug 1683744 - [OSP15] Nova Ephemeral over NFS forces v4 protocol instead of relying on version negotiation
Summary: [OSP15] Nova Ephemeral over NFS forces v4 protocol instead of relying on vers...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 15.0 (Stein)
Assignee: Martin Schuppert
QA Contact: Archit Modi
URL:
Whiteboard:
Depends On:
Blocks: 1691803 1691805
TreeView+ depends on / blocked
 
Reported: 2019-02-27 17:23 UTC by Federico Iezzi
Modified: 2019-09-26 10:48 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190429000408.3415df5.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1691803 1691805 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:20:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 643574 0 None MERGED Make nfs version for nova ephemeral storage configurable 2021-02-17 11:22:51 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:20:55 UTC

Description Federico Iezzi 2019-02-27 17:23:59 UTC
Description of problem:

Current Puppet Nova-compute configuration forces NFS version 4. This creates performance and scalability issues in basically all modern NFS environment where the standard is 4.1
Since RHEL 7.4, nfs 4.1 is fully supported and default too.

https://github.com/openstack/tripleo-heat-templates/blob/stable/queens/puppet/services/nova-compute.yaml#L300

Would be nice to remove the hardcoded "vers=4,nfsvers=4" (BTW it has been written twice)

Version-Release number of selected component (if applicable):
OSP13, OSP14, OSP15

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Martin Schuppert 2019-03-01 08:26:59 UTC
This was hard set to 4 to prevent users to use NFSv3 which has locking issues. I agree we should make this configurable where vers can be >=4 and defaults to 4.

Comment 2 Anil Dhingra 2019-03-08 06:05:26 UTC
so are we not suppose to use NFSv3 , i had a request from user they want to use NFSv3 - is it not supported

Comment 3 Martin Schuppert 2019-03-15 13:05:02 UTC
(In reply to Anil Dhingra from comment #2)
> so are we not suppose to use NFSv3 , i had a request from user they want to
> use NFSv3 - is it not supported

yes, NFSv3 is not supported due to locking. This has resulted in issues in the past.

Comment 8 Martin Schuppert 2019-03-20 08:34:24 UTC
(In reply to Martin Schuppert from comment #3)
> (In reply to Anil Dhingra from comment #2)
> > so are we not suppose to use NFSv3 , i had a request from user they want to
> > use NFSv3 - is it not supported
> 
> yes, NFSv3 is not supported due to locking. This has resulted in issues in
> the past.

One of the issue is https://bugzilla.redhat.com/show_bug.cgi?id=1547095 .
Also check https://access.redhat.com/solutions/2780381

Comment 16 errata-xmlrpc 2019-09-21 11:20:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.