Bug 1683761 - Changes to clusteringress.spec.nodePlacement are not applied
Summary: Changes to clusteringress.spec.nodePlacement are not applied
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Miciah Dashiel Butler Masters
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-27 18:10 UTC by Dan Mace
Modified: 2019-06-04 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:45 UTC
Github openshift cluster-ingress-operator pull 147 None None None 2019-03-04 21:21:55 UTC

Description Dan Mace 2019-02-27 18:10:23 UTC
Description of problem:

Changes to the clusteringress.spec.nodePlacement field are not applied to the cluster.


Version-Release number of selected component (if applicable):


How reproducible:

`oc edit -n openshift-ingress-operator/default` and set a new value for `.spec.nodePlacement`.


Actual results:

The ingress-operator does not update the router deployment with the node node placement values.

Expected results:

The routers for the clusteringress should be redeployed using the new nodePlacement values.

Additional info:

Comment 3 Hongan Li 2019-03-14 06:49:04 UTC
verified with 4.0.0-0.nightly-2019-03-13-233958 and the issue has been fixed.

edit ingresscontroller and add spec.nodePlacement like below then check deployment: 
```
  spec:
    nodePlacement:
      nodeSelector:
        matchLabels:
          router: router
```

$ oc get deployment -n openshift-ingress -o yaml | grep nodeSelector -A 1
        nodeSelector:
          router: router


remove nodePlacement from ingresscontroller then the nodeSelector of deployment is restored to default:
$ oc get deployment -n openshift-ingress -o yaml | grep nodeSelector -A 2
        nodeSelector:
          beta.kubernetes.io/os: linux
          node-role.kubernetes.io/worker: ""

Comment 5 errata-xmlrpc 2019-06-04 10:44:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.