Bug 1683763 - Changes to clusteringress.spec.namespaceSelector are not applied
Summary: Changes to clusteringress.spec.namespaceSelector are not applied
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Miciah Dashiel Butler Masters
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-27 18:14 UTC by Dan Mace
Modified: 2019-06-04 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:45 UTC
Github openshift cluster-ingress-operator pull 147 None None None 2019-03-04 21:22:39 UTC

Description Dan Mace 2019-02-27 18:14:38 UTC
Description of problem:

Changes to the clusteringress.spec.namespaceSelector field are not applied to the cluster.


Version-Release number of selected component (if applicable):


How reproducible:

`oc edit -n openshift-ingress-operator/default` and set a new value for `.spec.namespaceSelector`.


Actual results:

The ingress-operator does not update the router deployment with the new namespace selector value.

Expected results:

The routers for the clusteringress should be redeployed using the new namespace selector value.

Additional info:

Comment 3 Weibin Liang 2019-03-13 17:53:23 UTC
Tested and verified in v4.0.0-0.177.0.

The new value for `.spec.namespaceSelector` defined ingresscontrollers/default can be applied to router.

Comment 5 errata-xmlrpc 2019-06-04 10:44:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.