Bug 1683764 - 'openstack tripleo container image prepare default' does not provide downstream red hat registry/namespaces
Summary: 'openstack tripleo container image prepare default' does not provide downstre...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: beta
: 15.0 (Stein)
Assignee: Emilien Macchi
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-27 18:16 UTC by Marius Cornea
Modified: 2019-09-26 10:48 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-common-10.4.1-0.20190313060345.1377727.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:20:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:20:55 UTC

Description Marius Cornea 2019-02-27 18:16:23 UTC
Description of problem:
'openstack tripleo container image prepare default' does not provide downstream red hat registry/namespaces. Instead upstream registries/namespaces are present.

Version-Release number of selected component (if applicable):
python3-tripleoclient-11.2.1-0.20190227005637.5a3d657.el8ost.noarch
python3-tripleo-common-10.4.1-0.20190227000340.1d415e6.el8ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install tripleoclient from OSP15 repo
2. openstack tripleo container image prepare default --output-env-file /home/stack/containers-prepare-parameter.yaml --local-push-destination
3. Check containers-prepare-parameter.yaml content

Actual results:
Upstream registries/namespaces

Expected results:
Downstream red hat registries/namespaces should be present.

Additional info:

# Generated with the following on 2019-02-27T13:12:20.614138
#
#   openstack tripleo container image prepare default --output-env-file /home/stack/containers-prepare-parameter.yaml --local-push-destination
#

parameter_defaults:
  ContainerImagePrepare:
  - push_destination: true
    set:
      ceph_image: daemon
      ceph_namespace: docker.io/ceph
      ceph_tag: v3.2.1-stable-3.2-luminous-centos-7-x86_64
      name_prefix: centos-binary-
      name_suffix: ''
      namespace: docker.io/tripleomaster
      neutron_driver: null
      openshift_asb_namespace: docker.io/ansibleplaybookbundle
      openshift_asb_tag: latest
      openshift_cluster_monitoring_image: cluster-monitoring-operator
      openshift_cluster_monitoring_namespace: quay.io/coreos
      openshift_cluster_monitoring_tag: v0.1.1
      openshift_cockpit_image: kubernetes
      openshift_cockpit_namespace: docker.io/cockpit
      openshift_cockpit_tag: latest
      openshift_configmap_reload_image: configmap-reload
      openshift_configmap_reload_namespace: quay.io/coreos
      openshift_configmap_reload_tag: v0.0.1
      openshift_etcd_image: etcd
      openshift_etcd_namespace: registry.fedoraproject.org/latest
      openshift_etcd_tag: latest
      openshift_gluster_block_image: glusterblock-provisioner
      openshift_gluster_image: gluster-centos
      openshift_gluster_namespace: docker.io/gluster
      openshift_gluster_tag: latest
      openshift_grafana_namespace: docker.io/grafana
      openshift_grafana_tag: 5.2.1
      openshift_heketi_image: heketi
      openshift_heketi_namespace: docker.io/heketi
      openshift_heketi_tag: latest
      openshift_kube_rbac_proxy_image: kube-rbac-proxy
      openshift_kube_rbac_proxy_namespace: quay.io/coreos
      openshift_kube_rbac_proxy_tag: v0.3.1
      openshift_kube_state_metrics_image: kube-state-metrics
      openshift_kube_state_metrics_namespace: quay.io/coreos
      openshift_kube_state_metrics_tag: v1.3.1
      openshift_namespace: docker.io/openshift
      openshift_oauth_proxy_tag: v1.1.0
      openshift_prefix: origin
      openshift_prometheus_alertmanager_tag: v0.15.2
      openshift_prometheus_config_reload_image: prometheus-config-reloader
      openshift_prometheus_config_reload_namespace: quay.io/coreos
      openshift_prometheus_config_reload_tag: v0.23.2
      openshift_prometheus_node_exporter_tag: v0.16.0
      openshift_prometheus_operator_image: prometheus-operator
      openshift_prometheus_operator_namespace: quay.io/coreos
      openshift_prometheus_operator_tag: v0.23.2
      openshift_prometheus_tag: v2.3.2
      openshift_tag: v3.11.0
      tag: current-tripleo
    tag_from_label: rdo_version

Comment 1 Jon Schlueter 2019-02-27 19:44:20 UTC
it would be good to get 

https://review.openstack.org/#/c/603505/ landed upstream if the file is really not used, this would reduce a number of the required changes.  Then these changes fall into base OSP changes for default, ceph, openshift, and rhel containers (etcd?) 

It would be nice to reduce the required maintaince to keep this stuff just working and re-basing cleanly

Comment 2 Jon Schlueter 2019-02-27 19:46:16 UTC
a number of patche

Comment 3 Jon Schlueter 2019-03-01 04:00:38 UTC
another patch will be required to update default namespace and prefix entry

Comment 4 Victor Voronkov 2019-05-07 07:36:55 UTC
Verified on RHOS_TRUNK-15.0-RHEL-8-20190423.n.1

$ openstack tripleo container image prepare default --output-env-file /home/stack/containers-prepare-parameter123.yaml --local-push-destination

$ view containers-prepare-parameter123.yaml

# Generated with the following on 2019-05-07T03:33:36.907310
#
#   openstack tripleo container image prepare default --output-env-file /home/stack/containers-prepare-parameter123.yaml --local-push-destination
#

parameter_defaults:
  ContainerImagePrepare:
  - push_destination: true
    set:
      ceph_image: rhceph-3-rhel7
      ceph_namespace: registry.access.redhat.com/rhceph
      ceph_tag: latest
      name_prefix: openstack-
      name_suffix: ''
      namespace: registry.access.redhat.com/rhosp15
      neutron_driver: ovn
...

Comment 13 errata-xmlrpc 2019-09-21 11:20:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.