Bug 1683766 - clusteringress API resources are not validated
Summary: clusteringress API resources are not validated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Daneyon Hansen
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-27 18:26 UTC by Dan Mace
Modified: 2019-06-04 10:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:49 UTC
Github openshift cluster-ingress-operator pull 183 None None None 2019-04-02 12:56:24 UTC

Description Dan Mace 2019-02-27 18:26:52 UTC
Description of problem:

No field on a clusteringress resource is subject to any API validation whatsoever. There is also no reporting (on status) of any post-admission validation errors. Field content requirements should be articulated in the API docs, enforced in validation/admission/operator, and reported (as necessary) through status.

Today, setting invalid data on the clusteringress will simply cause a variety of things to go wrong rolling out the various pieces of a deployment, and the problems will only surface as generic availability status info and operator log messages.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Daneyon Hansen 2019-03-28 21:59:05 UTC
Multiple PR's are in queue to address this bug:

Adds IngressController CRD Validation & Generation: https://github.com/openshift/cluster-ingress-operator/pull/183
Dep bump for the above PR: https://github.com/openshift/cluster-ingress-operator/pull/185
Post admission Ingress validation: https://github.com/openshift/cluster-ingress-operator/pull/187
Dep bump for the above PR: https://github.com/openshift/cluster-ingress-operator/pull/186

The last outstanding item from the bug description is:

There is also no reporting (on status) of any post-admission validation errors.

Comment 3 Dan Mace 2019-04-02 12:56:25 UTC
Going to call this one resolved by https://github.com/openshift/cluster-ingress-operator/pull/183 for basic openapi validation and we'll open more BZs for specific field validations as necessary.

Comment 5 Hongan Li 2019-04-04 07:59:11 UTC
verified with 4.0.0-0.nightly-2019-04-03-202419 and "validation" has been added to CRD of IngressController.

Comment 7 errata-xmlrpc 2019-06-04 10:44:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.