Bug 1683777 - Create button of the ClusterLogging is missing from UI
Summary: Create button of the ClusterLogging is missing from UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: Salvatore Colangelo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-27 18:56 UTC by Jeff Cantrill
Modified: 2019-06-04 10:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (19.39 KB, text/plain)
2019-02-27 18:58 UTC, Jeff Cantrill
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:49 UTC

Description Jeff Cantrill 2019-02-27 18:56:09 UTC
Description of problem:

While testing changes to ClusterLogging csv for https://github.com/operator-framework/community-operators/pull/85 the "Create Button" is missing which allows creation of CL instance via the UI


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Deploy CL operator via Operator Hub
2. Click Cluster Logging
3. Click Cluster Logging tab

Actual results: No button. See screen shot


Expected results: Button


Additional info:

Comment 1 Jeff Cantrill 2019-02-27 18:58:14 UTC
Created attachment 1539250 [details]
screenshot

Comment 2 Jian Zhang 2019-02-28 02:50:21 UTC
Thanks for your report! But, this issue belongs to the Operator itself or the UI, nothing with the OLM.
Transfer it to Logging component.

Comment 3 Jeff Cantrill 2019-02-28 16:35:31 UTC
(In reply to Jian Zhang from comment #2)
> Thanks for your report! But, this issue belongs to the Operator itself or
> the UI, nothing with the OLM.

Is OLM not the component which provides the UI.  The cluster logging operator has no control or means to affect the UI unless there is some hint in the CSV that is missing.  Moving back to OLM per the original advisement by Jessica

Comment 4 Jian Zhang 2019-03-04 08:54:01 UTC
Jeff,

> Actual results: No button. See screen shot

I think the "button" belongs to the static component of UI. What do you think?

Comment 6 Evan Cordell 2019-04-08 18:49:34 UTC
https://github.com/openshift/console/pull/1343 Should be fixed here

Comment 10 Salvatore Colangelo 2019-05-03 10:05:39 UTC
The Button now is present

Comment 12 errata-xmlrpc 2019-06-04 10:44:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.