Bug 168378 - CVE-2005-2917 Squid malformed NTLM authentication DoS
CVE-2005-2917 Squid malformed NTLM authentication DoS
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: squid (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
impact=moderate,reported=20050915,pub...
: Security
Depends On:
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-09-15 11:02 EDT by Josh Bressers
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHSA-2006-0052
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:50:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Bressers 2005-09-15 11:02:56 EDT
This issue comes from upstream:
http://www.squid-cache.org/Versions/v2/2.5/bugs/#squid-2.5.STABLE10-NTLM-scheme_assert

It seems that the squid server supports NTLM authentication, it is possible to
crash the squid server.
Comment 1 Josh Bressers 2005-09-15 11:03:27 EDT
This issue may also affect RHEL2.1 and RHEL3
Comment 2 Martin Stransky 2005-11-10 05:58:56 EST
RHEL2.1 isn't affected by this issue because it doesn't have NTLM helper...
Comment 3 Josh Bressers 2005-11-23 16:51:00 EST
I have removed this bug from the RHEL3U7CanFix list (bug 168424).  This bug is
for RHEL4.  I have filed bug 174029 to cover RHEL3U7.
Comment 5 Red Hat Bugzilla 2006-03-07 13:50:17 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2006-0052.html

Note You need to log in before you can comment on or make changes to this bug.