Bug 1683792 - ART payload includes manifests from older misnamed ose-marketplace-operator image
Summary: ART payload includes manifests from older misnamed ose-marketplace-operator i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.1.0
Assignee: Tim Bielawa
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-27 19:46 UTC by aravindh
Modified: 2019-06-04 10:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:49 UTC

Description aravindh 2019-02-27 19:46:38 UTC
Description of problem:
We ran into an issue where we found two copies of marketplace operator's manifests in the CVO payload. A while back our operator image was misnamed. This was fixed in https://github.com/openshift/ocp-build-data/commit/4efdaed3afc7bbb2d00310f1a4e25eb2067c037a. But the older image `openshift/ose-marketplace-operator` is still present in Brew or somewhere in the build pipeline. Please remove this so that it does not get picked up in the payload. It also needs to be deleted in the integration image streams.

How reproducible: Always


Steps to Reproduce:
1. Launch a cluster using the payload created by ART
2. Extract the payload using oc adm release extract --from=registry.svc.ci.openshift.org/openshift/origin-release@sha256:<insertsha>  --to=release-image 
3. Check the release-image directory and you will see two sets of manifests:

Actual results:
# ls release-image/ | grep marketplace
0000_70_marketplace-operator_01_namespace.yaml
0000_70_marketplace-operator_02_catalogsourceconfig.crd.yaml
0000_70_marketplace-operator_03_operatorsource.crd.yaml
0000_70_marketplace-operator_04_service_account.yaml
0000_70_marketplace-operator_05_role.yaml
0000_70_marketplace-operator_06_role_binding.yaml
0000_70_marketplace-operator_07_redhat_operatorsource.cr.yaml
0000_70_marketplace-operator_08_certified_operatorsource.cr.yaml
0000_70_marketplace-operator_09_community_operatorsource.cr.yaml
0000_70_marketplace-operator_10_operator.yaml
0000_70_operator-marketplace_01_namespace.yaml
0000_70_operator-marketplace_02_catalogsourceconfig.crd.yaml
0000_70_operator-marketplace_03_operatorsource.crd.yaml
0000_70_operator-marketplace_04_service_account.yaml
0000_70_operator-marketplace_05_role.yaml
0000_70_operator-marketplace_06_role_binding.yaml
0000_70_operator-marketplace_07_redhat_operatorsource.cr.yaml
0000_70_operator-marketplace_08_certified_operatorsource.cr.yaml
0000_70_operator-marketplace_09_community_operatorsource.cr.yaml
0000_70_operator-marketplace_10_operator.yaml
0000_70_operator-marketplace_11_clusteroperator.yaml


Expected results:
# ls release-image/ | grep marketplace
0000_70_operator-marketplace_01_namespace.yaml
0000_70_operator-marketplace_02_catalogsourceconfig.crd.yaml
0000_70_operator-marketplace_03_operatorsource.crd.yaml
0000_70_operator-marketplace_04_service_account.yaml
0000_70_operator-marketplace_05_role.yaml
0000_70_operator-marketplace_06_role_binding.yaml
0000_70_operator-marketplace_07_redhat_operatorsource.cr.yaml
0000_70_operator-marketplace_08_certified_operatorsource.cr.yaml
0000_70_operator-marketplace_09_community_operatorsource.cr.yaml
0000_70_operator-marketplace_10_operator.yaml
0000_70_operator-marketplace_11_clusteroperator.yaml

Comment 5 errata-xmlrpc 2019-06-04 10:44:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.