Bug 1683885 - roles/ceph-defaults/defaults/main.yml Incompatible W/ RHEL 8/Python3
Summary: roles/ceph-defaults/defaults/main.yml Incompatible W/ RHEL 8/Python3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-28 03:18 UTC by acalhoun
Modified: 2020-01-31 12:46 UTC (History)
12 users (show)

Fixed In Version: ceph-ansible-4.0.0-0.rc3.43.g8edb0646.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:45:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3866 0 'None' closed Automatic backport of pull request #3864 2020-03-01 19:55:20 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:46:06 UTC

Description acalhoun 2019-02-28 03:18:34 UTC
Description of problem:
task redhat_package_dependencies  within  roles/ceph-defaults/defaults/main.yml fails due to the python packages not including the specific python version on the package name. This is due to the changes in RHEL8 pertaining to python. 

Issue was resolved when changing the following:

roles/ceph-defaults/defaults/main.yml
------
80 redhat_package_dependencies:
81   - python-pycurl
82   - python-setuptools
++++++
80 redhat_package_dependencies:
81   - python3-pycurl
82   - python3-setuptools

Version-Release number of selected component (if applicable):
ceph-ansible.noarch  4.0.0-0.beta1.29.g3930791c.el8

How reproducible:
always

Steps to Reproduce:
1.run ansible-playbook site.yml 
2.
3.

Actual results:
ceph-ansible fails to locate dependencies 

Expected results:
installation of redhat package dependencies resolves successfully 

Additional info:

Comment 1 Ken Dreyer (Red Hat) 2019-03-04 17:01:23 UTC
Guillaume I wonder why we need these at all.

Comment 4 Ken Dreyer (Red Hat) 2019-04-17 16:43:31 UTC
This is in the stable-4.0 branch now upstream. I'll build a new git snapshot to get this change downstream.

Comment 11 errata-xmlrpc 2020-01-31 12:45:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.