Bug 168411 - PCI ids should be matched with largest pattern first
PCI ids should be matched with largest pattern first
Status: CLOSED DUPLICATE of bug 166708
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-15 15:59 EDT by Pierre Ossman
Modified: 2014-03-16 22:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 12:14:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2005-09-15 15:59:57 EDT
Description of problem:
Brooktree 878 based video cards exists as analog and digital (DVB) versions.
These use the same PCI id but different subsystem id.

The problem with kudzu is that is matches the bt878 driver first (which only has
a PCI id pattern) instead of the most specific snd-bt87x driver. The logic
should be changed so that more specific patterns are given priority.

bt878:
alias:          pci:v0000109Ed00000878sv*sd*bc*sc*i*

snd-bt87x:
alias:          pci:v0000109Ed00000878sv00000070sd000013EBbc*sc*i*
alias:          pci:v0000109Ed00000879sv00000070sd000013EBbc*sc*i*
alias:          pci:v0000109Ed00000878sv00000070sd0000FF01bc*sc*i*
Comment 1 Bill Nottingham 2005-09-16 12:14:38 EDT

*** This bug has been marked as a duplicate of 166708 ***

Note You need to log in before you can comment on or make changes to this bug.