Bug 1684162 - Obsolete the YUM-3 stack
Summary: Obsolete the YUM-3 stack
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zbigniew Jędrzejewski-Szmek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1709434 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-28 15:23 UTC by Michal Domonkos
Modified: 2019-09-18 00:02 UTC (History)
4 users (show)

Fixed In Version: fedora-obsolete-packages-31-32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-18 00:02:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Domonkos 2019-02-28 15:23:19 UTC
With the YUM-3 retirement[1] taking place in Fedora 31, we should ensure that the yum package is removed from the machine on a system upgrade.

Failing to do that, a system upgrade would fail due to an explicit conflict with yum in the dnf.spec file:
https://github.com/rpm-software-management/dnf/pull/1335/files

Note that it's probably sufficient to only deprecate the yum package; any other packages that are part of the YUM-3 stack (such as yum-utils or createrepo; for the complete list, see [2]) should be removed together with it since they require yum.

[1] https://fedoraproject.org/wiki/Changes/Retire_YUM_3
[2] https://fedoraproject.org/wiki/Changes/Retire_YUM_3#Detailed_Description

Comment 1 Miro Hrončok 2019-02-28 15:48:55 UTC
(In reply to Michal Domonkos from comment #0)
> Note that it's probably sufficient to only deprecate the yum package; any
> other packages that are part of the YUM-3 stack (such as yum-utils or
> createrepo; for the complete list, see [2]) should be removed together with
> it since they require yum.

This is not how it works AFAK. They will need to be obsoleted for exactly the reason that they require yum.

One question: Shouldn't yum be provided and obsoleted from dnf? Will it provide the symbolic link? (The same for createrepo and createrepo_c etc.)

Comment 2 Zbigniew Jędrzejewski-Szmek 2019-03-01 12:47:25 UTC
dnf-yum provides the symlink. I agree that it'd be nicest to do the Obsoletes from this package.

Comment 3 Michal Domonkos 2019-03-01 12:57:13 UTC
OK guys, thanks for the feedback, I have proposed the following:

https://github.com/rpm-software-management/dnf/pull/1337

In the meantime, let me think this through with my team a little more, to see which packages (if any) we would like to get obsoleted from fedora-obsolete-packages.

Comment 4 Miro Hrončok 2019-06-24 22:14:01 UTC
which packages (if any) you would like to get obsoleted from fedora-obsolete-packages?

Comment 5 Ben Cotton 2019-08-13 16:57:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 6 Ben Cotton 2019-08-13 19:09:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 7 Miro Hrončok 2019-09-03 16:00:16 UTC
Closing here, no answer for months.

Comment 8 Michal Domonkos 2019-09-03 16:16:10 UTC
Yeah, sorry about that, I was going to close this one out anyway.  It turned out we don't intend to put any obsoletes in this package.  Any quirks in the yum->dnf upgrade path will be resolved in the respective spec files instead.  Thanks again.

Comment 9 Michal Domonkos 2019-09-04 14:01:26 UTC
After having talked to a peer (Jaroslav Mracek) on my team, it's become apparent that, after all, the best way to handle the obsoletion of the individual yum plugins would be via fedora-obsolete-packages, especially since "yum-utils" is already there as I learned today and the plugins come from the same SRPM (and so we should keep the obsoletions in one place).

That said, I would like to request, in addition to "yum-utils" and "yum-metadata-parser" which are already there, to also obsolete the following packages:

* yum-NetworkManager-dispatcher
* yum-plugin-aliases
* yum-plugin-auto-update-debug-info
* yum-plugin-changelog
* yum-plugin-copr
* yum-plugin-fastestmirror
* yum-plugin-filter-data
* yum-plugin-fs-snapshot
* yum-plugin-keys
* yum-plugin-list-data
* yum-plugin-local
* yum-plugin-merge-conf
* yum-plugin-ovl
* yum-plugin-post-transaction-actions
* yum-plugin-priorities
* yum-plugin-protectbase
* yum-plugin-ps
* yum-plugin-puppetverify
* yum-plugin-refresh-updatesd
* yum-plugin-remove-with-leaves
* yum-plugin-rpm-warm-cache
* yum-plugin-show-leaves
* yum-plugin-tmprepo
* yum-plugin-tsflags
* yum-plugin-upgrade-helper
* yum-plugin-verify
* yum-plugin-versionlock

I am really sorry for the initial confusion and delay that led to the closure of this BZ.

Comment 10 Miro Hrončok 2019-09-04 14:12:13 UTC
What versions?

Comment 11 Michal Domonkos 2019-09-04 14:14:01 UTC
< 1.1.31-520 (same as yum-utils)

Comment 12 Michal Domonkos 2019-09-05 16:05:57 UTC
*** Bug 1709434 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2019-09-12 09:03:53 UTC
FEDORA-2019-83cd1332d7 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-83cd1332d7

Comment 14 Fedora Update System 2019-09-12 14:45:10 UTC
fedora-obsolete-packages-31-31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-83cd1332d7

Comment 15 Fedora Update System 2019-09-12 20:42:22 UTC
FEDORA-2019-83cd1332d7 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-83cd1332d7

Comment 16 Fedora Update System 2019-09-14 01:39:48 UTC
fedora-obsolete-packages-31-32 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-83cd1332d7

Comment 17 Fedora Update System 2019-09-18 00:02:56 UTC
fedora-obsolete-packages-31-32 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.