Bug 1684167 - Performance regression when using xxdiff
Summary: Performance regression when using xxdiff
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qt
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1701744
TreeView+ depends on / blocked
 
Reported: 2019-02-28 15:37 UTC by Andrew Mike
Modified: 2019-11-01 20:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1701744 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:19:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
xxdiff test suite (9.81 MB, application/gzip)
2019-02-28 15:37 UTC, Andrew Mike
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2349 None None None 2019-08-06 13:19:07 UTC

Description Andrew Mike 2019-02-28 15:37:18 UTC
Created attachment 1539565 [details]
xxdiff test suite

Description of problem: xxdiff appears to have performance issues when using the Qt libraries from RHEL 7.6 (as opposed to 7.4).


Version-Release number of selected component (if applicable):
qt-4.8.7-2.el7

How reproducible: Consistently.


Steps to Reproduce:
Download the attached test package and follow the instructions in the README.


Actual results: xxdiff slows down by an order of magnitude when linked against the  Qt 4.8.7 libraries.

Expected results: xxdiff shows no performance slowdown when linked against the Qt 4.8.7 libraries.

Additional info:

Comment 3 Andrew Mike 2019-02-28 15:41:03 UTC
The libraries that came with the test package are the Qt 4.8.5 libraries that were shipped with RHEL 7.4, so it seems there's a performance regression.

Comment 14 Michael Boisvert 2019-04-23 17:04:31 UTC
Using the reproducer is #c7, qt-4.8.7-3.el7 takes a few seconds and qt-4.8.7-2.el7 takes well over a minute to complete, verified.

Comment 17 errata-xmlrpc 2019-08-06 13:19:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2349


Note You need to log in before you can comment on or make changes to this bug.