Bug 16843 - nested %ifs don't work.
nested %ifs don't work.
Status: CLOSED DUPLICATE of bug 14463
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Depends On:
  Show dependency treegraph
Reported: 2000-08-24 03:26 EDT by Oleg Makarenko
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-08-24 04:59:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
the spec file that doesn't work (538 bytes, text/plain)
2000-08-24 03:27 EDT, Oleg Makarenko
no flags Details

  None (edit)
Description Oleg Makarenko 2000-08-24 03:26:20 EDT
I activly use the following code in spec files:

%define test1 0
%define test2 0

%if %{test1}
%if %{test2}

That works ok with rpm 3.0.4-0.48 but fails with 3.0.5-9.6x. The error
message is:
parse error in expression
(spec file name):(%if %{test1} line number): parseExpressionBoolean returns

The same script works fine if test1 == 1...
Comment 1 Oleg Makarenko 2000-08-24 03:27:59 EDT
Created attachment 2898 [details]
the spec file that doesn't work
Comment 2 Huang, Chih-Wei 2000-08-24 04:59:17 EDT
I encountered the same bug when I tried to rebuild
kernel 2.2.16-3 from updates by rpm 3.0.5-9.6x.
It worked fine with 3.0.4-0.48
Comment 3 Jeff Johnson 2000-08-24 11:11:30 EDT

*** This bug has been marked as a duplicate of 14463 ***

Note You need to log in before you can comment on or make changes to this bug.