Bug 16843 - nested %ifs don't work.
Summary: nested %ifs don't work.
Status: CLOSED DUPLICATE of bug 14463
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-24 07:26 UTC by Oleg Makarenko
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-24 08:59:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the spec file that doesn't work (538 bytes, text/plain)
2000-08-24 07:27 UTC, Oleg Makarenko
no flags Details

Description Oleg Makarenko 2000-08-24 07:26:20 UTC
I activly use the following code in spec files:

%define test1 0
%define test2 0
%prep
%build

%if %{test1}
%if %{test2}
%else
%endif
%endif

That works ok with rpm 3.0.4-0.48 but fails with 3.0.5-9.6x. The error
message is:
parse error in expression
(spec file name):(%if %{test1} line number): parseExpressionBoolean returns
-1

The same script works fine if test1 == 1...

Comment 1 Oleg Makarenko 2000-08-24 07:27:59 UTC
Created attachment 2898 [details]
the spec file that doesn't work

Comment 2 Huang, Chih-Wei 2000-08-24 08:59:17 UTC
I encountered the same bug when I tried to rebuild
kernel 2.2.16-3 from updates by rpm 3.0.5-9.6x.
It worked fine with 3.0.4-0.48

Comment 3 Jeff Johnson 2000-08-24 15:11:30 UTC

*** This bug has been marked as a duplicate of 14463 ***


Note You need to log in before you can comment on or make changes to this bug.