Bug 1684329 - Creating cluster logging from web console (Installed Operators) tries to install clusterlogging CR to default namespace
Summary: Creating cluster logging from web console (Installed Operators) tries to inst...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 01:28 UTC by Mike Fiedler
Modified: 2019-06-04 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:57 UTC
Github operator-framework community-operators pull 85 None None None 2019-03-01 18:13:11 UTC

Description Mike Fiedler 2019-03-01 01:28:58 UTC
Description of problem:

Not sure if this belongs to Logging, web console or OperatorHub.   Whoever owns the YAML used as an example to create a clusterlogging CR from web console is who this should go to.

Creating a new clusterlogging CR from the web gives sample YAML to install it in the default namespace.  Since https://github.com/operator-framework/community-operators/pull/85 clusterlogging CRs should only go to the openshift-logging namespace

1. Install the cluster logging operators from the web console (Catalog->OperatorHub->Show community operators)
2. Catalog->Installed Operators->Copied->Cluster Logging
3. Create New Cluster Logging

The sample YAML is:

apiVersion: logging.openshift.io/v1alpha1
kind: ClusterLogging
metadata:
  name: instance
  namespace: default
spec:
  managementState: Managed
  logStore:
    type: elasticsearch
    elasticsearch:
      nodeCount: 3
      redundancyPolicy: SingleRedundancy
      storage:
        storageClassName: gp2
        size: 200G
  visualization:
    type: kibana
    kibana:
      replicas: 1
  curation:
    type: curator
    curator:
      schedule: 30 3 * * *
  collection:
    logs:
      type: fluentd
      fluentd: {}




Version-Release number of selected component (if applicable): 4.0.0-0.nightly-2019-02-27-213933


How reproducible: Always

Comment 1 Jeff Cantrill 2019-03-01 18:13:12 UTC
Updated example to include 'openshift-logging' for the namespace.

Comment 2 Mike Fiedler 2019-03-06 15:21:32 UTC
Not fixed in 4.0.0-0.nightly-2019-03-06-074438 .  Do we need something to happen upstream?   Moving back to POST for now.

Comment 3 Jeff Cantrill 2019-03-06 16:37:25 UTC
Fixed here [1].  I was able to use the latest installer and the example though there seems to be some issue creating the clusterlogging instance via the UI

[1] https://github.com/operator-framework/community-operators/pull/85/files#diff-4ec4e2f434877037809540bb01ad313cR25

Comment 5 Qiaoling Tang 2019-03-14 09:01:03 UTC
Verified in 4.0.0-0.nightly-2019-03-13-233958

Comment 7 errata-xmlrpc 2019-06-04 10:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.