Bug 1684397 - Should update application-template-custombuild.json in origin repo
Summary: Should update application-template-custombuild.json in origin repo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.1.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 07:38 UTC by wewang
Modified: 2019-06-04 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:57 UTC

Description wewang 2019-03-01 07:38:35 UTC
Description of problem:
With Openshift v4.0, will not provide an accessible docker socket for use within a custom build image. so should update image and remove exposeDockerSocket in  https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-custombuild.json  
Version-Release number of selected component (if applicable):
v4.0 

How reproducible:
always 

Steps to Reproduce:
1. Check application-template-custombuild.json from origin repo 
2.
3.

Actual results:
had builder image which is build by docker 

Expected results:
should have custom image builded by buildah

Additional info:
Add new custom build cases for 4.0

Comment 1 Ben Parees 2019-03-01 14:04:21 UTC
Adam, We should just remove that sample entirely, it's being replaced by the tutorial defined in https://github.com/openshift/openshift-docs/pull/13876

Comment 2 Adam Kaplan 2019-03-06 19:23:15 UTC
PR to remove template: https://github.com/openshift/origin/pull/22261

Comment 3 wewang 2019-03-12 05:38:03 UTC
The custom related places already updated, verified it.

Comment 6 errata-xmlrpc 2019-06-04 10:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.