Bug 1684407 - Missing auth Prometheus endpoint coverage
Summary: Missing auth Prometheus endpoint coverage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Erica von Buelow
QA Contact: scheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 08:09 UTC by Chuan Yu
Modified: 2019-06-04 10:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:57 UTC

Description Chuan Yu 2019-03-01 08:09:16 UTC
Description of problem:
In 3.x there are some auth Prometheus endpoint coverage, such as, openshift_auth_basic_password_count, openshift_auth_basic_password_count_result, openshift_auth_form_password_count and openshift_auth_form_password_count_result, but all missing in 4.0

Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION     AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.6   True        False         44m       Cluster version is 4.0.0-0.6

How reproducible:
always

Steps to Reproduce:
Setup OCP 4.0 cluster, and open Prometheus console, try to query some auth endpoint

Actual results:
Missing auth Prometheus endpoint  

Expected results:
Should have auth Prometheus endpoint coverage

Additional info:

Comment 4 scheng 2019-04-17 06:52:33 UTC
There is still no successful nightly builds contain the PR(https://github.com/openshift/cluster-authentication-operator/pull/92).
Will verify this ASAP.

Comment 5 scheng 2019-04-19 06:10:37 UTC
Verified

Comment 7 errata-xmlrpc 2019-06-04 10:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.