Bug 1684420 - [regression] singular definition in bundlebinding CRD is not correct
Summary: [regression] singular definition in bundlebinding CRD is not correct
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Shawn Hurley
QA Contact: Zhang Cheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 08:58 UTC by Zihan Tang
Modified: 2019-06-04 10:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:58 UTC

Description Zihan Tang 2019-03-01 08:58:31 UTC
Description of problem:
singular definition in bundlebinding CRD is not correct
  names:
    .......
    singular: bundleebinding
singular should be 'bundlebinding'


Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-02-28-054829
ASB operator: docker.io/automationbroker/automation-broker-operator:v4.0
ASB version : 1.4.4
How reproducible:
awlays

Steps to Reproduce:
1. install asb through marketplace&OLM
2. check bindlebinding  CR and CRD
3.

Actual results:
singular definition is not right

$ oc get crd bundlebindings.automationbroker.io -o yaml
apiVersion: apiextensions.k8s.io/v1beta1
kind: CustomResourceDefinition
metadata:
  creationTimestamp: 2019-03-01T03:47:43Z
  generation: 1
  name: bundlebindings.automationbroker.io
  resourceVersion: "72390"
.......
    type: date
  group: automationbroker.io
  names:
    kind: BundleBinding
    listKind: BundleBindingList
    plural: bundlebindings
    singular: bundleebinding
  scope: Namespaced

$ oc get bundlebinding
error: the server doesn't have a resource type "bundlebinding"

Expected results:
singular definition should be 'bundlebinding'

Additional info:

Comment 3 Zihan Tang 2019-03-08 03:15:01 UTC
Verified.
 names:
    kind: BundleBinding
    listKind: BundleBindingList
    plural: bundlebindings
    singular: bundlebinding

Cluster version is 4.0.0-0.nightly-2019-03-05-065158

Comment 6 errata-xmlrpc 2019-06-04 10:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.