Bug 1684443 - [marketplace]The updating on csc doesn't work when it is created 3 hours later
Summary: [marketplace]The updating on csc doesn't work when it is created 3 hours later
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: aravindh
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 09:53 UTC by Fan Jia
Modified: 2019-06-04 10:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: bug 1684049 Consequence: Updating CSC stopped working Fix: See bug 1684049 Result: CSC updates work after 3 hours
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:58 UTC

Description Fan Jia 2019-03-01 09:53:12 UTC
Description of problem:
The updating on csc doesn't work when it is created 3 hours later,registory pod won't be updated even edit the csc's package manually

Version-Release number of selected component (if applicable):
clusterversion:4.0.0-0.nightly-2019-02-27-213933
marketplace image:quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:db3741fada8ffb0417e20b58781d2028a17c2c7697c0965b248b6af8501ef312
olm image:quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:767bf5dd077f8b2562e729e73b63425f035384d927e48c4dfdce8cb39beb20ac

How reproducible:
always

Steps to Reproduce:
1.install operator "federationv2" to ns "openshift-operatos" through the operator hub UI,the csc "installed-community-openshift-operators" will be created with the package "federationv2" 
2.wait for 3 hours
3. install another community operator "etcd" to ns "openshift-operatos" through the operator hub UI

Actual results:
1. after the step3 the csc "installed-community-openshift-operators" will add the package "etcd" to the package list.but the registory pod of "installed-community-openshift-operators-xxxxxx" won't be updated, and the package of "etcd" won't be download to the registory pod.


Expected results:
1. after step 3 the egistory pod of "installed-community-openshift-operators-xxxxxx" should be recreated and download the package of "etcd"

Additional info:
1. this can be reproduce at any kind of csc ,no matter it is created by yaml file manually or created by UI.
2. the registory pod won't be updated even edit the csc's package manually after it is created for 3 hours
3.if you delete the csc and create it again ,it can be updated correct again
4. the logs of markektplace :
`time="2019-03-01T06:00:03Z" level=info msg="Reconciling CatalogSourceConfig openshift-marketplace/installed-community-openshift-operators\n"
time="2019-03-01T06:00:03Z" level=info msg="No action taken, the object has already been reconciled" name=installed-community-openshift-operators targetNamespace=openshift-operators type=CatalogSourceConfig
`

Comment 1 Jian Zhang 2019-03-01 14:19:53 UTC
FYI, based on my understanding, I guess this issue maybe was caused by the bug 1684049

Comment 2 aravindh 2019-03-04 18:44:49 UTC
Fan Jia, given what Jian Zhang mentioned, please retest this with a build that has the fix for bug 1684049 and let me know if you still see the issue.

Comment 3 Fan Jia 2019-03-05 07:17:16 UTC
test env:
4.0.0-0.nightly-2019-03-04-234414

the csc project can be updated after it is created 3 hours later.

Comment 6 errata-xmlrpc 2019-06-04 10:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.