Bug 168449 - iproute - ip refuses to follow its own advice
iproute - ip refuses to follow its own advice
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iproute (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-16 00:27 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.6.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-19 02:59:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-09-16 00:27:52 EDT
Description of problem:

# ip help
Object "help" is unknown, try "ip help".

Hm..., somewhat circular even if 'ip --help', 'ip -help' and even 'ip -h'
do work.

Also up to know it was possible to type 'ip ro', 'ip ad', and 'ip'
was coming back with reasonable answers.  The current version insists that
everything has to be spelled out: 'ip route', 'ip addr' and so on.  Not a bug
but a PITA, entirely for free, after years of accepting shortened forms.

Version-Release number of selected component (if applicable):
iproute-2.6.14-1

How reproducible:
always
Comment 1 Radek Vokal 2005-09-16 03:46:14 EDT
This was a boggus behaviour. Even more funky options like `ip hel` worked. Now
help option is no longer supported, use -h or --help instead. Same with short
options for route and address. Don't use them, they are unsopported! 
Comment 2 Michal Jaegermann 2005-09-16 11:36:06 EDT
Well, the fact that 'ip' puts clearly on your screen

      try "ip help"

while this is not supported anymore (bummer!) is surely a bug.
Comment 3 Radek Vokal 2005-09-19 02:59:26 EDT
You're right. It's in commands list so I'm adding it back to work .. Fixed in
rawhide

Note You need to log in before you can comment on or make changes to this bug.