Bug 1684558 - Remove hard dependency on docker
Summary: Remove hard dependency on docker
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: colin
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: user-cont-team+packit-fas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 14:27 UTC by Lukas Slebodnik
Modified: 2019-05-21 01:13 UTC (History)
5 users (show)

Fixed In Version: colin-0.3.1-3.fc30 colin-0.3.1-2.fc29 colin-0.3.1-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-19 06:13:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Slebodnik 2019-03-01 14:27:42 UTC
Description of problem:
colin can work with docker, podman and ostree

It would be good to remove hard dependency on docker. It will allow us to reduce installed dependency in case we are interested just in podman or ostree

Version-Release number of selected component (if applicable):
sh$ rpm -q python3-colin
python3-colin-0.3.1-1.fc29.noarch

How reproducible:
Deterministic

Steps to Reproduce:
1. dnf repoquery --requires python3-colin

Actual results:
Description of problem:
conu can work with docker, podman and k8s/openshift

It would be good to remove hard dependency on conu. It will allow us to reduce installed dependency in case we are interested just in podman or k8s

Version-Release number of selected component (if applicable):
rpm -q python3-conu
python3-conu-0.7.0-1.fc29.noarch

How reproducible:
Deterministic

Steps to Reproduce:
1. dnf repoquery --requires python3-colin --resolve

Actual results:
sh-4.4# dnf repoquery --requires python3-colin --resolve
Last metadata expiration check: 0:07:00 ago on Fri 01 Mar 2019 02:18:42 PM UTC.
docker-2:1.13.1-65.git1185cfd.fc29.x86_64
python3-0:3.7.2-4.fc29.i686
python3-0:3.7.2-4.fc29.x86_64
python3-click-0:6.7-9.fc29.noarch
python3-conu-0:0.7.0-1.fc29.noarch
python3-dockerfile-parse-0:0.0.11-3.fc29.noarch
python3-fmf-0:0.6-1.fc29.noarch
python3-pyyaml-0:4.2-0.1.b4.fc29.x86_64
python3-six-0:1.11.0-6.fc29.noarch


Expected results:
sh-4.4# dnf repoquery --requires python3-colin --resolve
Last metadata expiration check: 0:07:00 ago on Fri 01 Mar 2019 02:18:42 PM UTC.
python3-0:3.7.2-4.fc29.i686
python3-0:3.7.2-4.fc29.x86_64
python3-click-0:6.7-9.fc29.noarch
python3-conu-0:0.7.0-1.fc29.noarch
python3-dockerfile-parse-0:0.0.11-3.fc29.noarch
python3-fmf-0:0.6-1.fc29.noarch
python3-pyyaml-0:4.2-0.1.b4.fc29.x86_64
python3-six-0:1.11.0-6.fc29.noarch


Additional info:
NOTE: python3-docker does not depend on docker package 

You might use weak dependencies (Recommends/Suggests) if you do not want to remove it completely from spec.

Comment 1 Lukas Slebodnik 2019-03-01 14:29:17 UTC
This is related to 1677664. And partially blocked by change in conu becasue colin depends on conu.

Comment 2 Tomas Tomecek 2019-03-01 16:08:45 UTC
Lukas, how serious is the issue? Should we prioritize it?

Is your expectation really just smaller install footprint?

Comment 3 Lukas Slebodnik 2019-03-01 18:57:00 UTC
(In reply to Tomas Tomecek from comment #2)
> Lukas, how serious is the issue? Should we prioritize it?
> 
> Is your expectation really just smaller install footprint?

Yes, jsut smaller install footprint.

I can send PRs to dist-git; just let me know.

Comment 4 Tomas Tomecek 2019-03-06 16:20:42 UTC
We would gladly accept your PRs!

Comment 6 Fedora Update System 2019-05-10 13:27:18 UTC
colin-0.3.1-3.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-275144859c

Comment 7 Fedora Update System 2019-05-10 13:27:46 UTC
colin-0.3.1-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9b5125d979

Comment 8 Fedora Update System 2019-05-10 13:28:31 UTC
colin-0.3.1-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ec066793a1

Comment 9 Fedora Update System 2019-05-11 02:10:42 UTC
colin-0.3.1-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-275144859c

Comment 10 Fedora Update System 2019-05-11 04:24:06 UTC
colin-0.3.1-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9b5125d979

Comment 11 Fedora Update System 2019-05-11 23:07:17 UTC
colin-0.3.1-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ec066793a1

Comment 12 Fedora Update System 2019-05-19 06:13:41 UTC
colin-0.3.1-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-05-19 10:27:02 UTC
colin-0.3.1-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-05-21 01:13:25 UTC
colin-0.3.1-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.