Bug 168457 - chkconfig-1.3.13.2-1 bug when use LSB compliant "Required-Start:"
chkconfig-1.3.13.2-1 bug when use LSB compliant "Required-Start:"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: chkconfig (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Ben Levenson
:
: 163389 172457 (view as bug list)
Depends On:
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-09-16 06:03 EDT by blossom
Modified: 2014-03-16 22:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2006-0018
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:33:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description blossom 2005-09-16 06:03:28 EDT
Description of problem:
when using LSB compliant "Required-Start:" , chkconfig does not create the 
appropriate Snnfoo scripts.
This can result in Start and Stop scripts not being run in the sequential order 
that the developer intended these scripts to be run.
Additionally, chkconfig creates S-1foo named scripts, which are not removed 
when one executes # chkconfig --del foo

Version-Release number of selected component (if applicable):
chkconfig-1.3.13.2-1

How reproducible:
Always
cat /etc/init.d/foo 
#!/bin/sh #
# chkconfig:      345 40 60
# description:    foo script
# Required-Start: $network

Steps to Reproduce 1 bug:
# chkconfig --list foo service foo supports chkconfig, but is not referenced in 
any runlevel (run 'chkconfig --add foo')
# chkconfig --add foo
# find . -name "*foo*"
./rc6.d/K60foo
./init.d/foo
./rc2.d/K60foo
./rc4.d/S-1foo    <=== huh?
./rc1.d/K60foo
./rc0.d/K60foo
./rc5.d/S-1foo    <=== huh?
./rc3.d/S-1foo    <=== huh?

Actual results:
./rc4.d/S-1foo    <=== huh?
./rc5.d/S-1foo    <=== huh?
./rc3.d/S-1foo    <=== huh?

Expected results:
./rc4.d/S40foo    
./rc5.d/S40foo   
./rc3.d/S40foo    

Steps to reproduce 2 bug
# chkconfig --del foo

Actual results
# find . -name "*foo*"
./init.d/foo
./rc4.d/S-1foo
./rc5.d/S-1foo
./rc3.d/S-1foo
Comment 1 Bill Nottingham 2005-09-16 12:16:12 EDT

*** This bug has been marked as a duplicate of 161870 ***
Comment 2 Bill Nottingham 2005-10-07 16:13:40 EDT
Reopening, this is not a duplicate of 161870.
Comment 3 Bill Nottingham 2005-10-07 16:15:36 EDT
*** Bug 163389 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2005-11-04 15:15:38 EST
*** Bug 172457 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2005-11-10 18:31:19 EST
Built in 1.3.13.3.
Comment 14 Red Hat Bugzilla 2006-03-07 13:33:08 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0018.html

Note You need to log in before you can comment on or make changes to this bug.