Bug 16846 - Can't use rpm --rebuild after update
Can't use rpm --rebuild after update
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-24 04:28 EDT by Thomas Svenson
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-24 04:28:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Svenson 2000-08-24 04:28:33 EDT
System: Dell Inspiron 3700

I installed RH 6.2, and then all the official updates for it. I also
compiled a new kernel (2.2.16) and the pcmcia pack (3.1.19), plus installed
a lilo from rawhide that has lba32 support.

Then I tried to rebuild som src.rpm packs. It failed in the end when the
binary rpm-pack was to be created.

The problem seems to be with the rpm updates (that is rpm itself) for 6.2.
When I made a fallback to the original 6.2 rpm I could rebuild the packs
again without any problems.
Comment 1 Jeff Johnson 2000-08-24 11:47:22 EDT
rpm-3.0.5 has the same default configuration for building that rpm-4.0 does.
Either
	1) fix the (now legacy) package that you are building (recommended)
	2) use rpm-3.0.4 or earlier to build (easy)
	3) use rpm-3.0.4 macros with rpm-3.0.5) (will work, of questionable utility).

Note You need to log in before you can comment on or make changes to this bug.