Bug 168464 - HTTP Configuration Tool Corrupts httpd.conf file
HTTP Configuration Tool Corrupts httpd.conf file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-16 10:49 EDT by Ashley Wise
Modified: 2015-03-04 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 10:36:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Corrupted httpd.conf created by GUI HTTP config tool (32.97 KB, text/plain)
2005-09-16 10:52 EDT, Ashley Wise
no flags Details
Good original httpd.conf file (32.04 KB, text/plain)
2005-09-16 10:52 EDT, Ashley Wise
no flags Details
truncated audit log (SELinux?) (68.79 KB, text/plain)
2005-09-16 11:00 EDT, Ashley Wise
no flags Details

  None (edit)
Description Ashley Wise 2005-09-16 10:49:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
The default httpd.conf file (I'll attach it later) works fine. The httpd service can start and stop without problem.

When you open the GUI HTTP Configuration Tool Desktop->System Settings->Server Settings->HTTP, and then do anything or nothing, and then click OK, first it asks if you want to save or exit (Yes), then (if the httpd.conf is still the default file) it asks "The configuration file has been manually modified. Overwrite?"

If you choose "Yes", then it copies the original default httpd.conf to httpd.conf.back, and writes an entirely new and different httpd.conf (I'll also attach that later).

This new httpd.conf file is corrupt somehow. As long as that new file is in place, the httpd servie will always fail to start.

There's no entries in the httpd log. The problem still occurs even when SELinux is disabled for httpd. I'll also attached the audit log.

If I move the backed-up pre-corrupted httpd.conf file back into place, then httpd can start up again.

Version-Release number of selected component (if applicable):
httpd-2.0.54-10

How reproducible:
Always

Steps to Reproduce:
1. Run HTTP configuration tool
2. Choose Yes to overwrite "manually edited" httpd.conf
3. Start httpd service
  

Actual Results:  httpd service fails to start

Expected Results:  It should have started

Additional info:
Comment 1 Ashley Wise 2005-09-16 10:52:06 EDT
Created attachment 118895 [details]
Corrupted httpd.conf created by GUI HTTP config tool
Comment 2 Ashley Wise 2005-09-16 10:52:57 EDT
Created attachment 118896 [details]
Good original httpd.conf file
Comment 3 Ashley Wise 2005-09-16 11:00:40 EDT
Created attachment 118897 [details]
truncated audit log (SELinux?)
Comment 4 Phil Knirsch 2005-11-04 10:30:07 EST
I've looked at your config file and the problem is that the Server Name has to
be a valid hostname.

Currently the tool doesn't check for this, so an invalid entry will result in an
invalid httpd.conf file.

Simply putting something like ashslinuxserver as name should work fine.

I'll see if i can fix it in one of the next versions.

Read ya, Phil
Comment 5 Phil Knirsch 2005-11-04 10:36:06 EST
OK, found a nice way to check it with a dialog box poping up if you specified an
invalid name.

Fix will be in next build.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.