Bug 1684677 - hamcrest fails to install
Summary: hamcrest fails to install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: ant
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1685312 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 20:43 UTC by Alex Scheel
Modified: 2019-05-17 06:43 UTC (History)
9 users (show)

Fixed In Version: ant-1.10-2820190409082750.819b5873
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-17 06:43:57 UTC


Attachments (Terms of Use)

Description Alex Scheel 2019-03-01 20:43:28 UTC
Description of problem:

Under Rawhide,

> # dnf install -y hamcrest

Will fail due to a broken package:

> Last metadata expiration check: 0:06:16 ago on Fri 01 Mar 2019 03:33:40 PM EST.
> Error: 
>  Problem: package hamcrest-1.3-25.fc30.noarch requires hamcrest-core = 1.3-25.fc30, but none of the providers can be installed
>   - conflicting requests
>   - package hamcrest-core-1.3-25.fc30.noarch is excluded
> (try to add '--skip-broken' to skip uninstallable packages)

In particular, hamcrest @ 1.3-25 depends on hamcrest-core = 1.3-25, but only hamcrest-core = 1.3-23.module_2512+68251d4e can be provided (from the ant module).

Version-Release number of selected component (if applicable):

hamcrest @ 1.3-25.fc30
hamcrest-core @ 1.3-23.module_2512+68251d4e

How reproducible:

Very

Steps to Reproduce:
1. Install a fresh Rawhide system
2. dnf install -y hamcrest

Actual results:

Hamcrest can't be installed.

Expected results:

Hamcrest should be installable, either directly or as part of the ant module. The dependencies shouldn't be broken.

Comment 1 Mikolaj Izdebski 2019-03-01 22:12:40 UTC
Confirmed. The primary cause of this problem is that hamcrest package is filtered out of ant module. Due to strict requires, hamcrest from fedora can't be installed with hamcrest-core from ant module. Long term solution will involve making hamcrest-core from fedora-modular parallel-installable with hamcrest-core from fedora repo. Short term workaround involves removing filter from ant module.

Blocked on releng ticket: https://pagure.io/releng/issue/8125

Comment 2 Mikolaj Izdebski 2019-03-05 11:34:46 UTC
*** Bug 1685312 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2019-04-17 13:23:14 UTC
ant-1.10-2820190409091957.819b5873 has been pushed to the Fedora 30 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2019-05-17 03:26:18 UTC
ant-1.10-2820190507144348.819b5873 has been pushed to the Fedora 28 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2019-05-17 03:50:01 UTC
ant-1.10-2820190507144406.819b5873 has been pushed to the Fedora 29 Modular stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.