Bug 1684678 - operator hub page doesn't show installed community operator without clicking "show community"
Summary: operator hub page doesn't show installed community operator without clicking ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Jeff Phillips
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 20:46 UTC by Erik M Jacobs
Modified: 2019-06-04 10:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: UX design was to show community operators only when the user confirmed showing them. Consequence: Users had to clicl 'Show Community Operators' before the community operators would display. Fix: Show community operators by default and add an indicator to the community operators' tiles. Result: Community operators are shown by default and have a community 'badge'
Clone Of:
Environment:
Last Closed: 2019-06-04 10:44:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:44:58 UTC

Description Erik M Jacobs 2019-03-01 20:46:27 UTC
Description of problem:

When you visit the operator hub page within the web UI, installed community operators are not shown in the list until you click "show community" -- even if they are already installed.

I would expect that all installed operators would be shown by default, even if they are community. 

Version-Release number of selected component (if applicable):
4.0.0-0.6

How reproducible:
100%

Steps to Reproduce:
1. install a community operator
2. leave the operator hub page
3. return to the operator hub page

Actual results:
installed community operators not shown by default

Expected results:
installed community operators should be shown

Additional info:
It just feels weird to have to click something extra to see _installed_ operators, if that makes sense.

Feel free to CLOSEDWONTFIX this, it's more of a brain dump.

Comment 1 Samuel Padgett 2019-03-01 20:49:35 UTC
This should be fixed by https://github.com/openshift/console/pull/1178

Comment 2 XiaochuanWang 2019-03-08 06:06:31 UTC
Now it does not seen on 4.0.0-0.nightly-2019-03-06-074438.

The community operators are displayed well after browsed to some other pages such as Pod page then go back. It also works when the whole page close and reopen.
If this is the same thing as the step2 "leave the operator hub page", I think it could be moved to Verified.

Comment 5 errata-xmlrpc 2019-06-04 10:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.